aboutsummaryrefslogtreecommitdiffstats
path: root/package/shfs
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-01-05 20:36:06 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-01-05 20:36:06 +0000
commit10f15193a2e09c23ef8fc84d6a88251fe0357ad3 (patch)
tree3631e1f6fc2be37ec6619edc759d1aabb5ad4f27 /package/shfs
parent3f881e9573a891a64a806238680fe958c00df527 (diff)
downloadupstream-10f15193a2e09c23ef8fc84d6a88251fe0357ad3.tar.gz
upstream-10f15193a2e09c23ef8fc84d6a88251fe0357ad3.tar.bz2
upstream-10f15193a2e09c23ef8fc84d6a88251fe0357ad3.zip
Convert kmod-shfs to the KernelPackage template
SVN-Revision: 6001
Diffstat (limited to 'package/shfs')
-rw-r--r--package/shfs/Makefile16
1 files changed, 5 insertions, 11 deletions
diff --git a/package/shfs/Makefile b/package/shfs/Makefile
index 0ba866b0f1..ae99df3926 100644
--- a/package/shfs/Makefile
+++ b/package/shfs/Makefile
@@ -34,16 +34,16 @@ define Package/shfs/Default
URL:=http://shfs.sourceforge.net/
endef
-define Package/kmod-shfs
+define KernelPackage/shfs
$(call Package/shfs/Default)
- SECTION:=kernel
- CATEGORY:=Kernel drivers
- DEPENDS+=
TITLE+= (kernel module)
DESCRIPTION+=\\\
\\\
This package contains the ShFS kernel module.
+ FILES:=$(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.$(LINUX_KMOD_SUFFIX)
+ SUBMENU:=Network Support
VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+ AUTOLOAD:=$(call AutoLoad,40,shfs)
endef
define Package/shfs-utils
@@ -77,12 +77,6 @@ define Build/Compile
utils utils-install
endef
-define Package/kmod-shfs/install
- $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
- $(CP) $(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.$(LINUX_KMOD_SUFFIX) \
- $(1)/lib/modules/$(LINUX_VERSION)/
-endef
-
define Package/shfs-utils/install
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/shfs{,u}mount $(1)/usr/bin/
@@ -90,5 +84,5 @@ define Package/shfs-utils/install
$(CP) $(PKG_INSTALL_DIR)/sbin/mount.shfs $(1)/sbin/
endef
-$(eval $(call BuildPackage,kmod-shfs))
+$(eval $(call KernelPackage,shfs))
$(eval $(call BuildPackage,shfs-utils))