aboutsummaryrefslogtreecommitdiffstats
path: root/package/pwc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
commit5a325930579db5f9175bea19459c845746801ae4 (patch)
tree8b63e203323c3c4ab05aa9bf0a9ec17f5dc87c91 /package/pwc
parent7bc567a0409f4d9aa9a4e12e9c56bc892b737da3 (diff)
downloadupstream-5a325930579db5f9175bea19459c845746801ae4.tar.gz
upstream-5a325930579db5f9175bea19459c845746801ae4.tar.bz2
upstream-5a325930579db5f9175bea19459c845746801ae4.zip
replace lots of manual install commands with INSTALL_* variables
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5624 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/pwc')
-rw-r--r--package/pwc/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/pwc/Makefile b/package/pwc/Makefile
index b2c281eed8..0b5925b4c8 100644
--- a/package/pwc/Makefile
+++ b/package/pwc/Makefile
@@ -44,8 +44,8 @@ endef
define Package/kmod-pwc/install
mkdir -p $(1)/etc/modules.d
- install -m0644 ./files/pwc.modules $(1)/etc/modules.d/70-pwc
- install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
+ $(INSTALL_DATA) ./files/pwc.modules $(1)/etc/modules.d/70-pwc
+ $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
$(CP) $(PKG_BUILD_DIR)/pwc.$(LINUX_KMOD_SUFFIX) \
$(1)/lib/modules/$(LINUX_VERSION)/
endef