aboutsummaryrefslogtreecommitdiffstats
path: root/package/pptp
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-07-17 22:42:29 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-07-17 22:42:29 +0000
commit60fe01e698eb6f3c4b8af0c9b6b5a59f1bcb5ab3 (patch)
tree3945c27d420becbc7633959636747c6e155adc1b /package/pptp
parent28505cad0dd7be04aa706eda0a4bdae20d286788 (diff)
downloadupstream-60fe01e698eb6f3c4b8af0c9b6b5a59f1bcb5ab3.tar.gz
upstream-60fe01e698eb6f3c4b8af0c9b6b5a59f1bcb5ab3.tar.bz2
upstream-60fe01e698eb6f3c4b8af0c9b6b5a59f1bcb5ab3.zip
pptp: properly support symbolic VPN host names, tear down created host routes (#4876)
SVN-Revision: 27669
Diffstat (limited to 'package/pptp')
-rw-r--r--package/pptp/Makefile6
-rw-r--r--package/pptp/files/pptp.sh12
2 files changed, 13 insertions, 5 deletions
diff --git a/package/pptp/Makefile b/package/pptp/Makefile
index 184f72698c..08f6b40aa3 100644
--- a/package/pptp/Makefile
+++ b/package/pptp/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pptp
PKG_VERSION:=1.7.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/pptpclient
@@ -23,7 +23,7 @@ define Package/pptp
TITLE:=PPTP client
MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
URL:=http://pptpclient.sourceforge.net/
- DEPENDS:=+ppp +kmod-gre
+ DEPENDS:=+ppp +kmod-gre +resolveip
endef
define Package/pptp/description
diff --git a/package/pptp/files/pptp.sh b/package/pptp/files/pptp.sh
index 436bee3c87..7efbb02fb8 100644
--- a/package/pptp/files/pptp.sh
+++ b/package/pptp/files/pptp.sh
@@ -8,6 +8,9 @@ scan_pptp() {
stop_interface_pptp() {
stop_interface_ppp "$1"
+ for ip in $(uci_get_state network "$1" serv_addrs); do
+ route del -host "$ip" 2>/dev/null
+ done
}
coldplug_interface_pptp() {
@@ -39,8 +42,13 @@ setup_interface_pptp() {
setup_interface "$device" "$config" "${ipproto:-dhcp}"
local gw="$(find_gw)"
[ -n "$gw" ] && {
- [ "$gw" != 0.0.0.0 ] && route delete "$server" 2>/dev/null >/dev/null
- route add "$server" gw "$gw"
+ local serv_addrs=""
+ for ip in $(resolveip -4 -t 3 "$server"); do
+ append serv_addrs "$ip"
+ route delete -host "$ip" 2>/dev/null
+ route add -host "$ip" gw "$gw"
+ done
+ uci_toggle_state network "$config" serv_addrs "$serv_addrs"
}
# fix up the netmask