aboutsummaryrefslogtreecommitdiffstats
path: root/package/ppp
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-10-04 23:10:36 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-10-04 23:10:36 +0000
commit5659ec69182f34d66f59df41a55b4f6415a1e07d (patch)
tree5be5e80f2ac03c11bb592798203887428e1a78ff /package/ppp
parent829ae01f16404cd9b972108ba1ee49b25b12df17 (diff)
downloadupstream-5659ec69182f34d66f59df41a55b4f6415a1e07d.tar.gz
upstream-5659ec69182f34d66f59df41a55b4f6415a1e07d.tar.bz2
upstream-5659ec69182f34d66f59df41a55b4f6415a1e07d.zip
ppp: add workaround for ignored rp_pppoe_ac and rp_pppoe_service options by appending the nic-xxx argument last
SVN-Revision: 28364
Diffstat (limited to 'package/ppp')
-rw-r--r--package/ppp/Makefile2
-rw-r--r--package/ppp/files/ppp.sh10
-rw-r--r--package/ppp/files/pppoe.sh4
3 files changed, 12 insertions, 4 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index eed594361c..ed692103b4 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ppp
PKG_VERSION:=2.4.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
diff --git a/package/ppp/files/ppp.sh b/package/ppp/files/ppp.sh
index 996d542280..7c789fc983 100644
--- a/package/ppp/files/ppp.sh
+++ b/package/ppp/files/ppp.sh
@@ -16,6 +16,13 @@ stop_interface_ppp() {
start_pppd() {
local cfg="$1"; shift
+ # Workaround for PPPoE service and AC name options,
+ # filter out the nic-* argument and append it as last option
+ local nic=""
+ case "$1" in
+ nic-*) nic="$1"; shift ;;
+ esac
+
local proto
config_get proto "$cfg" proto
@@ -110,7 +117,8 @@ start_pppd() {
${disconnect:+disconnect "$disconnect"} \
${ipv6} \
${pppd_options} \
- nodetach
+ nodetach \
+ ${nic}
lock -u "/var/lock/ppp-${link}"
}
diff --git a/package/ppp/files/pppoe.sh b/package/ppp/files/pppoe.sh
index bbd36a11ab..99409f3f08 100644
--- a/package/ppp/files/pppoe.sh
+++ b/package/ppp/files/pppoe.sh
@@ -13,7 +13,7 @@ setup_interface_pppoe() {
config_get mtu "$config" mtu
mtu=${mtu:-1492}
start_pppd "$config" \
+ "nic-$iface" \
plugin rp-pppoe.so \
- mtu $mtu mru $mtu \
- "nic-$iface"
+ mtu $mtu mru $mtu
}