aboutsummaryrefslogtreecommitdiffstats
path: root/package/ppp/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-07 08:34:51 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-07 08:34:51 +0000
commit2180fa92a1158fe8f660b3a69a8f9848309ce9b6 (patch)
tree0f9b6c1a366e3cdca242f1fbebe68337d21e3b7b /package/ppp/Makefile
parentf2b24749083122a565ebf96a9143cb763d17345e (diff)
downloadupstream-2180fa92a1158fe8f660b3a69a8f9848309ce9b6.tar.gz
upstream-2180fa92a1158fe8f660b3a69a8f9848309ce9b6.tar.bz2
upstream-2180fa92a1158fe8f660b3a69a8f9848309ce9b6.zip
move package description to a separate definition, remove it when DESCRIPTION=TITLE
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8659 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ppp/Makefile')
-rw-r--r--package/ppp/Makefile61
1 files changed, 38 insertions, 23 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index 20945852ce..df3f035099 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -28,64 +28,79 @@ define Package/ppp/Default
endef
define Package/ppp
- $(call Package/ppp/Default)
+$(call Package/ppp/Default)
DEPENDS:=+kmod-ppp
TITLE:=PPP daemon
- DESCRIPTION:=\
- This package contains the PPP (Point-to-Point Protocol) daemon.
MENU:=1
endef
+define Package/ppp/description
+ This package contains the PPP (Point-to-Point Protocol) daemon.
+endef
+
define Package/ppp-mod-pppoa
- $(call Package/ppp/Default)
+$(call Package/ppp/Default)
DEPENDS:=ppp +linux-atm +kmod-pppoa
TITLE:=PPPoA plugin
- DESCRIPTION:=\
- This package contains a PPPoA (PPP over ATM) plugin for ppp.
+endef
+
+define Package/ppp-mod-pppoa/description
+ This package contains a PPPoA (PPP over ATM) plugin for ppp.
endef
define Package/ppp-mod-pppoe
- $(call Package/ppp/Default)
+$(call Package/ppp/Default)
DEPENDS:=ppp +kmod-pppoe
TITLE:=PPPoE plugin
- DESCRIPTION:=\
- This package contains a PPPoE (PPP over Ethernet) plugin for ppp.
+endef
+
+define Package/ppp-mod-pppoe/description
+ This package contains a PPPoE (PPP over Ethernet) plugin for ppp.
endef
define Package/ppp-mod-radius
- $(call Package/ppp/Default)
+$(call Package/ppp/Default)
DEPENDS:=ppp
TITLE:=RADIUS plugin
- DESCRIPTION:=\
- This package contains a RADIUS (Remote Authentication Dial-In User \\\
- Service) plugin for ppp.
+endef
+
+define Package/ppp-mod-radius/description
+ This package contains a RADIUS (Remote Authentication Dial-In User
+ Service) plugin for ppp.
endef
define Package/chat
- $(call Package/ppp/Default)
+$(call Package/ppp/Default)
DEPENDS:=ppp
TITLE:=Establish conversation with a modem
- DESCRIPTION:=\
- This package contains an utility to establish conversation with other \\\
- PPP servers (via a modem).
+endef
+
+define Package/chat/description
+ This package contains an utility to establish conversation with other
+ PPP servers (via a modem).
endef
define Package/pppdump
- $(call Package/ppp/Default)
+$(call Package/ppp/Default)
DEPENDS:=ppp
TITLE:=Read PPP record file
- DESCRIPTION:=\
- This package contains an utility to read PPP record file.
+endef
+
+define Package/pppdump/description
+ This package contains an utility to read PPP record file.
endef
define Package/pppstats
- $(call Package/ppp/Default)
+$(call Package/ppp/Default)
DEPENDS:=ppp
TITLE:=Report PPP statistics
- DESCRIPTION:=\
- This package contains an utility to report PPP statistics.
endef
+define Package/pppstats/description
+ This package contains an utility to report PPP statistics.
+endef
+
+
define Build/Configure
$(call Build/Configure/Default,, \
UNAME_S="Linux" \