aboutsummaryrefslogtreecommitdiffstats
path: root/package/pjsip
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2010-11-03 19:12:34 +0000
committerJohn Crispin <john@openwrt.org>2010-11-03 19:12:34 +0000
commita8b2a07f375edefec242de9f20d4aefafa927517 (patch)
treed15f5bb696bfa9dfd9555788d411e0ba59b99a65 /package/pjsip
parent72ae8452cda47d6e18e664097a4adbc0eee3fc7b (diff)
downloadupstream-a8b2a07f375edefec242de9f20d4aefafa927517.tar.gz
upstream-a8b2a07f375edefec242de9f20d4aefafa927517.tar.bz2
upstream-a8b2a07f375edefec242de9f20d4aefafa927517.zip
* adds a rewrite of the tapi drivers + sip app. this is the result of lars' gsoc 2010 project, Thanks !
SVN-Revision: 23840
Diffstat (limited to 'package/pjsip')
-rw-r--r--package/pjsip/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/package/pjsip/Makefile b/package/pjsip/Makefile
new file mode 100644
index 0000000000..6216ebfc9a
--- /dev/null
+++ b/package/pjsip/Makefile
@@ -0,0 +1,58 @@
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pjsip
+PKG_VERSION:=1.6
+PKG_RELEASE:=1
+
+PKG_SOURCE:=pjproject-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://www.pjsip.org/release/1.6/
+#PKG_MD5SUM:=9b7dc52656f5cbec846a7ba3299f73bd
+PKG_INSTALL:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/pjproject-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/pjsip
+ SECTION:=lib
+ CATEGORY:=Libraries
+ TITLE:=Voip lib
+ URL:=http://www.pjsip.org/
+ DEPENDS:=+libuuid
+endef
+
+CONFIGURE_ARGS += \
+ --disable-sound \
+ --disable-oss \
+ --disable-ext-sound \
+ --disable-speex-aec \
+ --enable-g711-codec \
+ --disable-l16-codec \
+ --disable-gsm-codec \
+ --disable-g722-codec \
+ --disable-g7221-codec \
+ --disable-speex-codec \
+ --disable-ilbc-coder \
+ --disable-libsamplerate \
+ --disable-ipp \
+ --disable-ssl \
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/{include,lib}
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* \
+ $(1)/usr/include/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/* \
+ $(1)/usr/lib/
+endef
+
+define Package/pjsip/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+endef
+
+define Build/Compile
+ $(MAKE_VARS) $(MAKE) -C $(PKG_BUILD_DIR)/$(MAKE_PATH)
+endef
+
+
+$(eval $(call BuildPackage,pjsip))