aboutsummaryrefslogtreecommitdiffstats
path: root/package/opkg
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-13 20:54:01 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-13 20:54:01 +0000
commit99c9533a7fba2062d9f24378edba8939d5fd77dc (patch)
tree589429ef96ab272dc39bf2e6b94e9c443f0bf48c /package/opkg
parent45ac69c41067b4a14ab0b09dc3daf271fe8ba517 (diff)
downloadupstream-99c9533a7fba2062d9f24378edba8939d5fd77dc.tar.gz
upstream-99c9533a7fba2062d9f24378edba8939d5fd77dc.tar.bz2
upstream-99c9533a7fba2062d9f24378edba8939d5fd77dc.zip
opkg: remove manual automake invocations and rely and host and target fixups
SVN-Revision: 24554
Diffstat (limited to 'package/opkg')
-rw-r--r--package/opkg/Makefile13
1 files changed, 1 insertions, 12 deletions
diff --git a/package/opkg/Makefile b/package/opkg/Makefile
index 2870abdc03..4d702bae9c 100644
--- a/package/opkg/Makefile
+++ b/package/opkg/Makefile
@@ -18,6 +18,7 @@ PKG_SOURCE_SUBDIR:=opkg-$(PKG_VERSION)
PKG_SOURCE_URL:=http://opkg.googlecode.com/svn/trunk/
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
PKG_FIXUP = libtool
+PKG_REMOVE_FILES = autogen.sh aclocal.m4
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
@@ -53,13 +54,6 @@ CONFIGURE_ARGS += \
--with-opkgetcdir=/etc \
--with-opkglockfile=/var/lock/opkg.lock
-define Build/Configure
- (cd $(PKG_BUILD_DIR); \
- autoreconf -v --install || exit 1 \
- );
- $(call Build/Configure/Default)
-endef
-
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
@@ -91,11 +85,6 @@ HOST_CONFIGURE_ARGS+= \
--with-opkgetcdir=/etc \
--with-opkglockfile=/tmp/opkg.lock
-define Host/Configure
- (cd $(HOST_BUILD_DIR); autoreconf -v --install || exit 1)
- $(call Host/Configure/Default)
-endef
-
define Host/Compile
$(MAKE) -C $(HOST_BUILD_DIR) CC="$(HOSTCC)" all
endef