aboutsummaryrefslogtreecommitdiffstats
path: root/package/opkg
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-02 12:48:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-02 12:48:04 +0000
commit8c0df5f96c3b223009dd99ab3f2660c279984e91 (patch)
tree5ba445a921e6cb985d350aee3c6298a38079f26b /package/opkg
parent575a35c58d95c6dca64a4ccf478ebd4feb487482 (diff)
downloadupstream-8c0df5f96c3b223009dd99ab3f2660c279984e91.tar.gz
upstream-8c0df5f96c3b223009dd99ab3f2660c279984e91.tar.bz2
upstream-8c0df5f96c3b223009dd99ab3f2660c279984e91.zip
opkg: use -ffunction-sections, -fdata-sections and --gc-sections
SVN-Revision: 25829
Diffstat (limited to 'package/opkg')
-rw-r--r--package/opkg/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/opkg/Makefile b/package/opkg/Makefile
index 25cdc524c6..0b07d5b499 100644
--- a/package/opkg/Makefile
+++ b/package/opkg/Makefile
@@ -46,6 +46,7 @@ define Package/opkg/conffiles
endef
TARGET_CFLAGS += $(if $(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),-Wno-array-bounds)
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
CONFIGURE_ARGS += \
@@ -59,6 +60,7 @@ define Build/Compile
CC="$(TARGET_CC)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
HOST_CPU="$(PKGARCH)" \
+ LDFLAGS="-Wl,--gc-sections" \
all install
endef