aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-03-29 23:14:47 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-03-29 23:14:47 +0000
commit5e7f1abfe7a1ebc22bc73d11a56a2b00259b9e6f (patch)
tree35b5d95533a3d9ed442b56e8fe66ec4338a63ab9 /package/openssl
parentf011ebf4997d176b2532c871931702b0894aa3d8 (diff)
downloadupstream-5e7f1abfe7a1ebc22bc73d11a56a2b00259b9e6f.tar.gz
upstream-5e7f1abfe7a1ebc22bc73d11a56a2b00259b9e6f.tar.bz2
upstream-5e7f1abfe7a1ebc22bc73d11a56a2b00259b9e6f.zip
[package] openssl: add patch for CVE-2010-0740 ("Record of death") vulnerability
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20592 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/Makefile2
-rw-r--r--package/openssl/patches/400-cve-2010-0740.patch15
2 files changed, 16 insertions, 1 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index e7a74905fd..9f80a98f39 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openssl
PKG_VERSION:=0.9.8m
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.openssl.org/source/ \
diff --git a/package/openssl/patches/400-cve-2010-0740.patch b/package/openssl/patches/400-cve-2010-0740.patch
new file mode 100644
index 0000000000..4c893eb38d
--- /dev/null
+++ b/package/openssl/patches/400-cve-2010-0740.patch
@@ -0,0 +1,15 @@
+--- a/ssl/s3_pkt.c
++++ b/ssl/s3_pkt.c
+@@ -291,9 +291,9 @@ again:
+ if (version != s->version)
+ {
+ SSLerr(SSL_F_SSL3_GET_RECORD,SSL_R_WRONG_VERSION_NUMBER);
+- /* Send back error using their
+- * version number :-) */
+- s->version=version;
++ if ((s->version & 0xFF00) == (version & 0xFF00))
++ /* Send back error using their minor version number :-) */
++ s->version = (unsigned short)version;
+ al=SSL_AD_PROTOCOL_VERSION;
+ goto f_err;
+ }