aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl/patches/150-no_engines.patch
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2008-05-20 18:12:08 +0000
committerSteven Barth <cyrus@openwrt.org>2008-05-20 18:12:08 +0000
commitf2de1dec21881b6300efbb7a636150bfe753424b (patch)
treeb0d68798a50a8b7aef6771ae54fcf852a273db77 /package/openssl/patches/150-no_engines.patch
parent0f662245cbebcb364a100c6c281bcbce21cb4c84 (diff)
downloadupstream-f2de1dec21881b6300efbb7a636150bfe753424b.tar.gz
upstream-f2de1dec21881b6300efbb7a636150bfe753424b.tar.bz2
upstream-f2de1dec21881b6300efbb7a636150bfe753424b.zip
Merge branch 'openssl'
SVN-Revision: 11224
Diffstat (limited to 'package/openssl/patches/150-no_engines.patch')
-rw-r--r--package/openssl/patches/150-no_engines.patch38
1 files changed, 18 insertions, 20 deletions
diff --git a/package/openssl/patches/150-no_engines.patch b/package/openssl/patches/150-no_engines.patch
index 104cba07a2..1c9e715439 100644
--- a/package/openssl/patches/150-no_engines.patch
+++ b/package/openssl/patches/150-no_engines.patch
@@ -1,7 +1,21 @@
-Index: openssl-0.9.8e/util/libeay.num
-===================================================================
---- openssl-0.9.8e.orig/util/libeay.num 2007-06-04 13:23:32.021865832 +0200
-+++ openssl-0.9.8e/util/libeay.num 2007-06-04 13:23:33.045710184 +0200
+diff -ur openssl-0.9.8g/Configure openssl-0.9.8g2/Configure
+--- openssl-0.9.8g/Configure 2008-05-19 22:49:45.000000000 +0200
++++ openssl-0.9.8g2/Configure 2008-05-19 22:50:40.000000000 +0200
+@@ -1685,6 +1685,11 @@
+ close(OUT);
+ }
+
++# ugly hack to disable engines
++if($target eq "mingwx") {
++ system("sed -e s/^LIB/XLIB/g -i engines/Makefile");
++}
++
+ print <<EOF;
+
+ Configured for $target.
+diff -ur openssl-0.9.8g/util/libeay.num openssl-0.9.8g2/util/libeay.num
+--- openssl-0.9.8g/util/libeay.num 2007-06-11 18:33:48.000000000 +0200
++++ openssl-0.9.8g2/util/libeay.num 2008-05-19 22:50:40.000000000 +0200
@@ -2071,7 +2071,6 @@
UI_add_error_string 2633 EXIST::FUNCTION:
KRB5_CHECKSUM_free 2634 EXIST::FUNCTION:
@@ -67,19 +81,3 @@ Index: openssl-0.9.8e/util/libeay.num
EC_GROUP_set_curve_name 3533 EXIST::FUNCTION:EC
X509_CERT_PAIR_it 3534 EXIST:!EXPORT_VAR_AS_FUNCTION:VARIABLE:
X509_CERT_PAIR_it 3534 EXIST:EXPORT_VAR_AS_FUNCTION:FUNCTION:
-Index: openssl-0.9.8e/Configure
-===================================================================
---- openssl-0.9.8e.orig/Configure 2007-06-04 13:23:32.598778128 +0200
-+++ openssl-0.9.8e/Configure 2007-06-04 13:23:33.046710032 +0200
-@@ -1644,6 +1644,11 @@
- close(OUT);
- }
-
-+# ugly hack to disable engines
-+if($target eq "mingwx") {
-+ system("sed -e s/^LIB/XLIB/g -i engines/Makefile");
-+}
-+
- print <<EOF;
-
- Configured for $target.