aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-07-12 15:42:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-07-12 15:42:00 +0000
commite3dcb74486e39693db69af83398fd083c95f4f36 (patch)
treecd64e0c409fc2906d3f2d4cf619df876914b6219 /package/openssl/Makefile
parent981105308f521e122b5c04ce5c778bd30bf4cc2b (diff)
downloadupstream-e3dcb74486e39693db69af83398fd083c95f4f36.tar.gz
upstream-e3dcb74486e39693db69af83398fd083c95f4f36.tar.bz2
upstream-e3dcb74486e39693db69af83398fd083c95f4f36.zip
enable openssl engine support on ixp4xx
SVN-Revision: 11788
Diffstat (limited to 'package/openssl/Makefile')
-rw-r--r--package/openssl/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 9fca6b1498..6eafc7ed7d 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -67,8 +67,13 @@ endef
OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc2 no-rc5 no-sha0 no-smime \
no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
+ifeq ($(BOARD),ixp4xx)
+OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-threads zlib-dynamic \
+ no-sse2 no-perlasm
+else
OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-threads zlib-dynamic \
no-engines no-sse2 no-perlasm
+endif
define Build/Configure