aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-25 22:15:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-25 22:15:37 +0000
commitd94301a65f65585f3cfa81f8c3e58a1641add5fa (patch)
tree61287d4a3794171bf916fdec29c0045812a3798d /package/openssl/Makefile
parent560f9c8b071cd1bf12a5474c97886eeb73186a26 (diff)
downloadupstream-d94301a65f65585f3cfa81f8c3e58a1641add5fa.tar.gz
upstream-d94301a65f65585f3cfa81f8c3e58a1641add5fa.tar.bz2
upstream-d94301a65f65585f3cfa81f8c3e58a1641add5fa.zip
sync openssl ciphers and options with whiterussian
SVN-Revision: 5644
Diffstat (limited to 'package/openssl/Makefile')
-rw-r--r--package/openssl/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 827c4415c0..9738c1ae5e 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -62,8 +62,11 @@ define Package/openssl-util/conffiles
/etc/ssl/openssl.cnf
endef
-OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-rmd160 no-aes192
-OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-krb5 no-threads zlib-dynamic no-engines
+OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc2 no-rc5 no-sha0 no-smime no-cast \
+ no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5 no-ssl2
+OPENSSL_OPTIONS:= shared no-dso no-ec no-err no-fips no-hw no-threads zlib-dynamic \
+ no-engines no-sse2 no-perlasm
+
define Build/Configure
(cd $(PKG_BUILD_DIR); \