aboutsummaryrefslogtreecommitdiffstats
path: root/package/odhcp6c/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2013-05-24 13:03:50 +0000
committerSteven Barth <steven@midlink.org>2013-05-24 13:03:50 +0000
commitd698f749801a0e0655829d0ea7e383bdfd0fad37 (patch)
treee71e7e4d3440d35e7a221838572f3f6a8382fa13 /package/odhcp6c/Makefile
parent545b4169d1a645c0263ce792f823345ac9c498d4 (diff)
downloadupstream-d698f749801a0e0655829d0ea7e383bdfd0fad37.tar.gz
upstream-d698f749801a0e0655829d0ea7e383bdfd0fad37.tar.bz2
upstream-d698f749801a0e0655829d0ea7e383bdfd0fad37.zip
AA: backport odhcp6c from trunk
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@36710 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/odhcp6c/Makefile')
-rw-r--r--package/odhcp6c/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/package/odhcp6c/Makefile b/package/odhcp6c/Makefile
new file mode 100644
index 0000000000..6c8934e7cc
--- /dev/null
+++ b/package/odhcp6c/Makefile
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=odhcp6c
+PKG_VERSION:=2013-05-21
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_VERSION:=6677edeab2d7472b97a34461872c2c8985d6a57c
+PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/odhcp6c
+ SECTION:=ipv6
+ CATEGORY:=IPv6
+ TITLE:=Embedded DHCPv6-client for OpenWrt
+ DEPENDS:=+kmod-ipv6
+endef
+
+define Package/odhcp6c/install
+ $(INSTALL_DIR) $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/odhcp6c $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/lib/netifd/proto
+ $(INSTALL_BIN) ./files/dhcpv6.sh $(1)/lib/netifd/proto/dhcpv6.sh
+ $(INSTALL_BIN) ./files/dhcpv6.script $(1)/lib/netifd/
+endef
+
+$(eval $(call BuildPackage,odhcp6c))