aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-09-16 16:27:37 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-09-16 16:38:19 -0700
commitef485bb23d207e0b1031d264a6fafce01d2bdf8f (patch)
tree9dab3b1caaad0808d54ec6cfadd1077570523e50 /package/network
parentba792ee2195e525a40f61aaec75982963ceaf209 (diff)
downloadupstream-ef485bb23d207e0b1031d264a6fafce01d2bdf8f.tar.gz
upstream-ef485bb23d207e0b1031d264a6fafce01d2bdf8f.tar.bz2
upstream-ef485bb23d207e0b1031d264a6fafce01d2bdf8f.zip
dnsmasq: Pass TARGET_CPPFLAGS to Makefile
With the introduction of the ubus notifications, we would now fail building dnsmasq with external toolchains that don't automatically search for headers. Pass TARGET_CPPFLAGS to the Makefile to resolve that. Fixes: 34a206bc1194 ("dnsmasq: add ubus notifications for new leases") Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/dnsmasq/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index 57870a53b6..331e5fabe3 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -138,7 +138,7 @@ endif
MAKE_FLAGS := \
$(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
+ CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
COPTS="$(COPTS)" \
PREFIX="/usr"