aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-21 17:40:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-21 17:40:59 +0000
commitd4760cd9b4c0d4f761eedd9d6aebb369f27b347a (patch)
treea64c01838d6f0a8a0d24e461315933c49f4395de /package/network
parent3babd37b0eecf72549c935d3579626c0189d208a (diff)
downloadupstream-d4760cd9b4c0d4f761eedd9d6aebb369f27b347a.tar.gz
upstream-d4760cd9b4c0d4f761eedd9d6aebb369f27b347a.tar.bz2
upstream-d4760cd9b4c0d4f761eedd9d6aebb369f27b347a.zip
uqmi: Add qmi.sh executable bit and fix option dhcp
Using protocol qmi does not work since qmi.sh is not executable. Setting option dhcp explicitely to 0 actually enables it. This patch fixes both problems. Signed-off-by: Matti Laakso <malaakso@elisanet.fi> SVN-Revision: 47014
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/uqmi/Makefile2
-rwxr-xr-x[-rw-r--r--]package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/utils/uqmi/Makefile b/package/network/utils/uqmi/Makefile
index 16e7fea0a9..7ccf549989 100644
--- a/package/network/utils/uqmi/Makefile
+++ b/package/network/utils/uqmi/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uqmi
-PKG_VERSION:=2015-08-13
+PKG_VERSION:=2015-09-17
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
diff --git a/package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh b/package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh
index 8ee7dbdecf..48864bea4b 100644..100755
--- a/package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh
+++ b/package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh
@@ -140,7 +140,7 @@ proto_qmi_setup() {
return 1
}
- if [ -z "$dhcp" ]; then
+ if [ -z "$dhcp" -o "$dhcp" = 0 ]; then
echo "Setting up $ifname"
[ -n "$ipv4" ] && {
json_load "$(uqmi -s -d $device --set-client-id wds,$cid_4 --get-current-settings)"