aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2021-04-12 16:46:22 -0700
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2021-04-24 12:21:40 +0100
commitcf20f1bb5f0479c2509dd651d08e235a3b9e8755 (patch)
tree1275067777a0816514124f9176a39257eb40e258 /package/network
parentc7a5a093efd0725ef170c6dacd414044020233d9 (diff)
downloadupstream-cf20f1bb5f0479c2509dd651d08e235a3b9e8755.tar.gz
upstream-cf20f1bb5f0479c2509dd651d08e235a3b9e8755.tar.bz2
upstream-cf20f1bb5f0479c2509dd651d08e235a3b9e8755.zip
bpftools: fix feature override for masking clang
Rename feature variable clang-bpf-global-var following upstream changes. This restores the HAVE_CLANG feature override and should avoid rare build errors where a recent host clang and BTF-enabled host kernel are present. Fixes: 23be333401f0 ("bpftools: update to 5.10.10") Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/bpftools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/utils/bpftools/Makefile b/package/network/utils/bpftools/Makefile
index 9955d361f4..52963e4148 100644
--- a/package/network/utils/bpftools/Makefile
+++ b/package/network/utils/bpftools/Makefile
@@ -128,7 +128,7 @@ define Build/Configure
| sort | uniq > FEATURE-DUMP.openwrt)
$(SED) 's/feature-libbfd=1/feature-libbfd=$(HAVE_LIBBFD)/' \
-e 's/feature-libcap=1/feature-libcap=$(HAVE_LIBCAP)/' \
- -e 's/feature-clang-bpf-global-var=1/feature-clang-bpf-global-var=$(HAVE_CLANG)/' \
+ -e 's/feature-clang-bpf-co-re=1/feature-clang-bpf-co-re=$(HAVE_CLANG)/' \
$(PKG_BUILD_DIR)/FEATURE-DUMP.openwrt
endef