aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2018-10-11 13:10:56 +0200
committerHans Dedecker <dedeckeh@gmail.com>2019-02-07 21:58:07 +0100
commitbdedb798150a58ad7ce3c4741f2f31df97e84c3f (patch)
tree7ae608a78322d826ca8ae8389e86dfd84e5770e4 /package/network
parent5fd68d60e422492dfad0d4f77f1bef3d0ea079ba (diff)
downloadupstream-bdedb798150a58ad7ce3c4741f2f31df97e84c3f.tar.gz
upstream-bdedb798150a58ad7ce3c4741f2f31df97e84c3f.tar.bz2
upstream-bdedb798150a58ad7ce3c4741f2f31df97e84c3f.zip
gre: remove setting default firewall zone to wan
There are two problems with this behaviour that the zone is set to wan if no zone config option is defined in the interface section. * The zone for the interface is "normally" specified in the firewall config file. So if we have defined "no" zone for this interface zone option is set now to "wan" additonaly if we add the interface in the firewall config section to the "lan" zone, the interface is added to lan and wan at once. iptables-save | grep <iface> This is not what I expect. * If I do not want to set a zone to this interface it is not possible. Remove the default assigment to wan if no zone option is defined. If some one need the option it stil possible to define this option. Signed-off-by: Florian Eckert <fe@dev.tdt.de> Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [PKG_RELEASE increase]
Diffstat (limited to 'package/network')
-rw-r--r--package/network/config/gre/Makefile2
-rwxr-xr-xpackage/network/config/gre/files/gre.sh1
2 files changed, 1 insertions, 2 deletions
diff --git a/package/network/config/gre/Makefile b/package/network/config/gre/Makefile
index a7e8612c6c..6fe6d567b9 100644
--- a/package/network/config/gre/Makefile
+++ b/package/network/config/gre/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gre
PKG_VERSION:=1
-PKG_RELEASE:=9
+PKG_RELEASE:=10
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/config/gre/files/gre.sh b/package/network/config/gre/files/gre.sh
index ca11e87cfd..2bb1010b76 100755
--- a/package/network/config/gre/files/gre.sh
+++ b/package/network/config/gre/files/gre.sh
@@ -16,7 +16,6 @@ gre_generic_setup() {
local mtu ttl tos zone ikey okey icsum ocsum iseqno oseqno multicast
json_get_vars mtu ttl tos zone ikey okey icsum ocsum iseqno oseqno multicast
- [ -z "$zone" ] && zone="wan"
[ -z "$multicast" ] && multicast=1
proto_init_update "$link" 1