aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorDobroslaw Kijowski <dobo90@gmail.com>2021-01-03 13:46:21 +0100
committerPaul Spooren <mail@aparcar.org>2021-06-20 14:11:30 -1000
commitbb2ac5a33be4c85c47f0f27e9ecb9e2c5f6c0a8f (patch)
treec1e6a458a8165d9510863d1c33a1142e9ffa6ed7 /package/network
parent2c6c1501af664490ec9b701b46a201e21c670b96 (diff)
downloadupstream-bb2ac5a33be4c85c47f0f27e9ecb9e2c5f6c0a8f.tar.gz
upstream-bb2ac5a33be4c85c47f0f27e9ecb9e2c5f6c0a8f.tar.bz2
upstream-bb2ac5a33be4c85c47f0f27e9ecb9e2c5f6c0a8f.zip
hostapd: stop advertising 11w feature
This is a follow up of 1a9b896d ("treewide: nuke DRIVER_11W_SUPPORT"). LuCI commit ab010406 ("luci-mod-network: skip check for 802.11w feature") skips check of the 11w feature [1]. Now advertising it in hostapd is superfluous so stop doing it. [1]: https://github.com/openwrt/luci/pull/4689 Signed-off-by: Dobroslaw Kijowski <dobo90@gmail.com> [remove outdated PKG_RELEASE bump and update to SPDX] Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/hostapd/Makefile6
-rw-r--r--package/network/services/hostapd/src/src/utils/build_features.h2
2 files changed, 2 insertions, 6 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 3c521b485d..fee6889b40 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -1,8 +1,6 @@
-# Copyright (C) 2006-2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
+# SPDX-License-Identifier: GPL-2.0-only
#
+# Copyright (C) 2006-2021 OpenWrt.org
include $(TOPDIR)/rules.mk
diff --git a/package/network/services/hostapd/src/src/utils/build_features.h b/package/network/services/hostapd/src/src/utils/build_features.h
index c7fccad413..3ab5246c78 100644
--- a/package/network/services/hostapd/src/src/utils/build_features.h
+++ b/package/network/services/hostapd/src/src/utils/build_features.h
@@ -23,8 +23,6 @@ static inline int has_feature(const char *feat)
if (!strcmp(feat, "11r"))
return 1;
#endif
- if (!strcmp(feat, "11w"))
- return 1;
#ifdef CONFIG_ACS
if (!strcmp(feat, "acs"))
return 1;