aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2020-08-25 23:54:44 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2020-08-26 21:00:42 +0200
commitb5191f3366c2bf09a8e0dfb08a4e0f5ca11bfd14 (patch)
treea4249ecbc0746b80d8c4bfd54d07ff6e0f856191 /package/network
parent18fbb9aa21740aa698af3d7e8e53a62d8ff014c9 (diff)
downloadupstream-b5191f3366c2bf09a8e0dfb08a4e0f5ca11bfd14.tar.gz
upstream-b5191f3366c2bf09a8e0dfb08a4e0f5ca11bfd14.tar.bz2
upstream-b5191f3366c2bf09a8e0dfb08a4e0f5ca11bfd14.zip
curl: Fix build with wolfssl
Backport a commit from upstream curl to fix a problem in configure with wolfssl. checking size of time_t... configure: error: cannot determine a size for time_t Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/curl/patches/100-configure-fix-pkg-config-detecting-wolfssl.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/package/network/utils/curl/patches/100-configure-fix-pkg-config-detecting-wolfssl.patch b/package/network/utils/curl/patches/100-configure-fix-pkg-config-detecting-wolfssl.patch
new file mode 100644
index 0000000000..a77e5c69df
--- /dev/null
+++ b/package/network/utils/curl/patches/100-configure-fix-pkg-config-detecting-wolfssl.patch
@@ -0,0 +1,31 @@
+From 510d98157f21dee5793c4e975fde3317b6139267 Mon Sep 17 00:00:00 2001
+From: Daniel Stenberg <daniel@haxx.se>
+Date: Mon, 24 Aug 2020 16:28:34 +0200
+Subject: [PATCH] configure: fix pkg-config detecting wolfssl
+
+When amending the include path with "/wolfssl", this now properly strips
+off all whitespace from the path variable! Previously this would lead to
+pkg-config builds creating bad command lines.
+
+Closes #5848
+---
+ configure.ac | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -2474,8 +2474,12 @@ if test -z "$ssl_backends" -o "x$OPT_WOL
+ AC_DEFINE(HAVE_WOLFSSL_DES_ECB_ENCRYPT, 1,
+ [if you have wolfSSL_DES_ecb_encrypt])
+ if test -n "$addcflags"; then
+- CPPFLAGS="$addcflags/wolfssl $CPPFLAGS"
+- AC_MSG_NOTICE([Add $addcflags/wolfssl to CPPFLAGS])
++ dnl use a for loop to strip off whitespace
++ for f in $addcflags; do
++ CPPFLAGS="$f/wolfssl $CPPFLAGS"
++ AC_MSG_NOTICE([Add $f/wolfssl to CPPFLAGS])
++ break
++ done
+ else
+ dnl user didn't give a path, so guess/hope they installed wolfssl
+ dnl headers to system default location