aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2021-06-23 11:58:51 -1000
committerPaul Spooren <mail@aparcar.org>2021-06-26 18:10:44 -1000
commitadddfe57870d96532b7a6ad2e142a5150f69da36 (patch)
tree595a76a453279507c10d67dcd0fb28534cb487a2 /package/network
parent76cc8a036ccb2355e301740ac2f51ac39894cd09 (diff)
downloadupstream-adddfe57870d96532b7a6ad2e142a5150f69da36.tar.gz
upstream-adddfe57870d96532b7a6ad2e142a5150f69da36.tar.bz2
upstream-adddfe57870d96532b7a6ad2e142a5150f69da36.zip
dante: move to packages.git
Rather than maintaining it in core, move it to packages.git where it's maintained by a community. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/dante/Makefile118
-rw-r--r--package/network/utils/dante/patches/200-fix-RTLD_NEXT.patch36
-rw-r--r--package/network/utils/dante/patches/210-deactivate-sched_setscheduler.patch53
3 files changed, 0 insertions, 207 deletions
diff --git a/package/network/utils/dante/Makefile b/package/network/utils/dante/Makefile
deleted file mode 100644
index 15bd6d2afc..0000000000
--- a/package/network/utils/dante/Makefile
+++ /dev/null
@@ -1,118 +0,0 @@
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=dante
-PKG_VERSION:=1.4.1
-PKG_RELEASE:=4
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.inet.no/dante/files/
-PKG_HASH:=b6d232bd6fefc87d14bf97e447e4fcdeef4b28b16b048d804b50b48f261c4f53
-
-PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
-PKG_LICENSE:=BSD-4-Clause
-
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-CONFIGURE_ARGS += \
- --without-upnp \
- --without-pam \
- --disable-libwrap
-
-CONFIGURE_VARS += \
- ac_cv_search_pam_start="" \
- ac_cv_func_sched_setscheduler=no
-
-define Build/InstallDev
- $(INSTALL_DIR) $(1)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{a,so*,la} $(1)/usr/lib/
-endef
-
-
-define Package/dante/default
- TITLE:=Dante SOCKS
- URL:=http://www.inet.no/dante/
-endef
-
-define Package/dante/default/description
-Dante is a circuit-level firewall/proxy that can be used to provide convenient
-and secure network connectivity, requiring only that the server Dante runs on
-has external network connectivity. Dante is used daily by Fortune 100 companies
-and large international organizations, either as a standard SOCKS server or as
-a "reverse proxy".
-endef
-
-define Package/libsocks
- $(call Package/dante/default)
- SECTION:=libs
- CATEGORY:=Libraries
- TITLE+= Library
- ABI_VERSION:=0
-endef
-
-define Package/libsocks/description
-$(call Package/dante/default/description)
-This package provides the shared libsocks library.
-endef
-
-define Package/libsocks/install
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsocks.so.* $(1)/usr/lib/
-endef
-
-
-define Package/sockd
- $(call Package/dante/default)
- SUBMENU:=Web Servers/Proxies
- SECTION:=net
- CATEGORY:=Network
- TITLE+= Daemon
-endef
-
-define Package/sockd/description
-$(call Package/dante/default/description)
-This package provides the Dante sockd daemon.
-endef
-
-define Package/sockd/install
- $(INSTALL_DIR) $(1)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/sockd $(1)/usr/sbin/
-endef
-
-
-define Package/socksify
- $(call Package/dante/default)
- SECTION:=net
- CATEGORY:=Network
- SUBMENU:=Web Servers/Proxies
- TITLE+= Client
-endef
-
-define Package/socksify/description
-$(call Package/dante/default/description)
-This package provides the Dante socksify client.
-endef
-
-define Package/socksify/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/socksify $(1)/usr/bin/
-
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdsocks.so* $(1)/usr/lib/
-endef
-
-
-$(eval $(call BuildPackage,libsocks))
-$(eval $(call BuildPackage,sockd))
-$(eval $(call BuildPackage,socksify))
diff --git a/package/network/utils/dante/patches/200-fix-RTLD_NEXT.patch b/package/network/utils/dante/patches/200-fix-RTLD_NEXT.patch
deleted file mode 100644
index 594a6f900b..0000000000
--- a/package/network/utils/dante/patches/200-fix-RTLD_NEXT.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/lib/address.c
-+++ b/lib/address.c
-@@ -48,11 +48,12 @@
-
- #include "upnp.h"
-
--#ifndef __USE_GNU
--#define __USE_GNU /* XXX for RTLD_NEXT on Linux */
--#endif /* !__USE_GNU */
- #include <dlfcn.h>
-
-+#ifndef RTLD_NEXT
-+#define RTLD_NEXT ((void *) -1l)
-+#endif
-+
- static const char rcsid[] =
- "$Id: address.c,v 1.288.4.4 2014/08/15 18:16:40 karls Exp $";
-
---- a/dlib/interposition.c
-+++ b/dlib/interposition.c
-@@ -93,11 +93,12 @@ write$NOCANCEL(HAVE_PROT_WRITE_1, HAVE_P
-
- #endif /* HAVE_DARWIN */
-
--#ifndef __USE_GNU
--#define __USE_GNU /* XXX for RTLD_NEXT on Linux */
--#endif /* !__USE_GNU */
- #include <dlfcn.h>
-
-+#ifndef RTLD_NEXT
-+#define RTLD_NEXT ((void *) -1l)
-+#endif
-+
- #ifdef __COVERITY__
- /*
- * Coverity naturally has no idea what the function sys_foo calls does,
diff --git a/package/network/utils/dante/patches/210-deactivate-sched_setscheduler.patch b/package/network/utils/dante/patches/210-deactivate-sched_setscheduler.patch
deleted file mode 100644
index e711189c59..0000000000
--- a/package/network/utils/dante/patches/210-deactivate-sched_setscheduler.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-When compiled with glibc the config_scan.c wants to use the
-cpupolicy2numeric() function which is only available when
-HAVE_SCHED_SETSCHEDULER is set. It looks like the wrong define was used here.
-
-This fixes a build problem with glibc in combination with the force
-ac_cv_func_sched_setscheduler=no in the OpenWrt CONFIGURE_VARS.
-
---- a/lib/config_scan.c
-+++ b/lib/config_scan.c
-@@ -3891,7 +3891,7 @@ YY_RULE_SETUP
- SERRX(0);
-
- #else /* !SOCKS_CLIENT */
--#if HAVE_SCHED_SETAFFINITY
-+#if HAVE_SCHED_SETSCHEDULER
-
- BEGIN(0);
-
-@@ -3899,9 +3899,9 @@ YY_RULE_SETUP
- yyerrorx("unknown scheduling policy \"%s\"", yytext);
-
- return SCHEDULEPOLICY;
--#else /* !HAVE_SCHED_SETAFFINITY */
-+#else /* !HAVE_SCHED_SETSCHEDULER */
- yyerrorx("setting cpu scheduling policy is not supported on this platform");
--#endif /* !HAVE_SCHED_SETAFFINITY */
-+#endif /* !HAVE_SCHED_SETSCHEDULER */
-
- #endif /* SOCKS_CLIENT */
- }
---- a/lib/config_scan.l
-+++ b/lib/config_scan.l
-@@ -456,7 +456,7 @@ cpu {
- SERRX(0);
-
- #else /* !SOCKS_CLIENT */
--#if HAVE_SCHED_SETAFFINITY
-+#if HAVE_SCHED_SETSCHEDULER
-
- BEGIN(0);
-
-@@ -464,9 +464,9 @@ cpu {
- yyerrorx("unknown scheduling policy \"%s\"", yytext);
-
- return SCHEDULEPOLICY;
--#else /* !HAVE_SCHED_SETAFFINITY */
-+#else /* !HAVE_SCHED_SETSCHEDULER */
- yyerrorx("setting cpu scheduling policy is not supported on this platform");
--#endif /* !HAVE_SCHED_SETAFFINITY */
-+#endif /* !HAVE_SCHED_SETSCHEDULER */
-
- #endif /* SOCKS_CLIENT */
- }