aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-07-10 10:53:29 +0200
committerJo-Philipp Wich <jo@mein.io>2017-07-10 11:02:27 +0200
commita89c36b50875e61c790113d3adee10621575788a (patch)
tree4a56d96564aa3f87d29bd7e7049bb7c17f878045 /package/network
parent9d07d2dc56a45ac0deb02a3b6ec7cceaaec89091 (diff)
downloadupstream-a89c36b50875e61c790113d3adee10621575788a.tar.gz
upstream-a89c36b50875e61c790113d3adee10621575788a.tar.bz2
upstream-a89c36b50875e61c790113d3adee10621575788a.zip
dnsmasq: restore ability to include/exclude raw device names
Commit 5cd88f4 "dnsmasq: remove use of uci state for getting network ifname" broke the ability to specify unmanaged network device names for inclusion and exclusion in the uci configuration. Restore support for raw device names by falling back to the input value when "network_get_device" yields no result. Fixes FS#876. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/dnsmasq/Makefile2
-rw-r--r--package/network/services/dnsmasq/files/dnsmasq.init4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index 401071fe92..070172464e 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_VERSION:=2.77
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq/
diff --git a/package/network/services/dnsmasq/files/dnsmasq.init b/package/network/services/dnsmasq/files/dnsmasq.init
index 19517d937d..6f985b2417 100644
--- a/package/network/services/dnsmasq/files/dnsmasq.init
+++ b/package/network/services/dnsmasq/files/dnsmasq.init
@@ -138,12 +138,12 @@ append_ipset() {
}
append_interface() {
- network_get_device ifname "$1" || return
+ network_get_device ifname "$1" || ifname="$1"
xappend "--interface=$ifname"
}
append_notinterface() {
- network_get_device ifname "$1" || return
+ network_get_device ifname "$1" || ifname="$1"
xappend "--except-interface=$ifname"
}