aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2021-07-27 20:13:40 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-08-08 19:50:46 +0200
commit97d88b1fbd62ad8a24b076d317c7408ee7012757 (patch)
tree711fac53c9fb1df226e415f1a2b85fe6745d4c22 /package/network
parent9df7eadcfd3129cecfb30ec78a43ae9b3175869e (diff)
downloadupstream-97d88b1fbd62ad8a24b076d317c7408ee7012757.tar.gz
upstream-97d88b1fbd62ad8a24b076d317c7408ee7012757.tar.bz2
upstream-97d88b1fbd62ad8a24b076d317c7408ee7012757.zip
iproute2: bump to 5.13
Drop patch 185-libbpf-add-limits-h merged upstream Update patch 170-ip_tiny Update patch 130-no_netem_tpic_dcb... Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/iproute2/Makefile6
-rw-r--r--package/network/utils/iproute2/patches/130-no_netem_tipc_dcb_man_vdpa.patch (renamed from package/network/utils/iproute2/patches/130-no_netem_tipc_dcb_man.patch)2
-rw-r--r--package/network/utils/iproute2/patches/170-ip_tiny.patch17
-rw-r--r--package/network/utils/iproute2/patches/185-libbpf-add-limits-h.patch45
4 files changed, 13 insertions, 57 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 54165636c7..1cd4833aba 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
-PKG_VERSION:=5.11.0
-PKG_RELEASE:=4
+PKG_VERSION:=5.13.0
+PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
-PKG_HASH:=c5e2ea108212b3445051b35953ec267f9f3469e1d5c67ac034ab559849505c54
+PKG_HASH:=72a2e53774cac9e65f7b617deebb2059f87e8960d6e9713e4d788cea966f1b36
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=iptables
PKG_LICENSE:=GPL-2.0
diff --git a/package/network/utils/iproute2/patches/130-no_netem_tipc_dcb_man.patch b/package/network/utils/iproute2/patches/130-no_netem_tipc_dcb_man_vdpa.patch
index e3faee0d8f..8ddb316744 100644
--- a/package/network/utils/iproute2/patches/130-no_netem_tipc_dcb_man.patch
+++ b/package/network/utils/iproute2/patches/130-no_netem_tipc_dcb_man_vdpa.patch
@@ -4,7 +4,7 @@
CFLAGS := $(WFLAGS) $(CCOPTS) -I../include -I../include/uapi $(DEFINES) $(CFLAGS)
YACCFLAGS = -d -t -v
--SUBDIRS=lib ip tc bridge misc netem genl tipc devlink rdma dcb man
+-SUBDIRS=lib ip tc bridge misc netem genl tipc devlink rdma dcb man vdpa
+SUBDIRS=lib ip tc bridge misc genl devlink rdma
LIBNETLINK=../lib/libutil.a ../lib/libnetlink.a
diff --git a/package/network/utils/iproute2/patches/170-ip_tiny.patch b/package/network/utils/iproute2/patches/170-ip_tiny.patch
index d5e5b36936..a0dde748c7 100644
--- a/package/network/utils/iproute2/patches/170-ip_tiny.patch
+++ b/package/network/utils/iproute2/patches/170-ip_tiny.patch
@@ -25,19 +25,20 @@
sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
--- a/ip/ip.c
+++ b/ip/ip.c
-@@ -64,10 +64,16 @@ static void usage(void)
+@@ -64,11 +64,17 @@ static void usage(void)
fprintf(stderr,
"Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }\n"
" ip [ -force ] -batch filename\n"
+#ifndef IPROUTE2_TINY
- "where OBJECT := { link | address | addrlabel | route | rule | neigh | ntable |\n"
- " tunnel | tuntap | maddress | mroute | mrule | monitor | xfrm |\n"
- " netns | l2tp | fou | macsec | tcp_metrics | token | netconf | ila |\n"
- " vrf | sr | nexthop | mptcp }\n"
+ "where OBJECT := { address | addrlabel | fou | help | ila | l2tp | link |\n"
+ " macsec | maddress | monitor | mptcp | mroute | mrule |\n"
+ " neighbor | neighbour | netconf | netns | nexthop | ntable |\n"
+ " ntbl | route | rule | sr | tap | tcpmetrics |\n"
+ " token | tunnel | tuntap | vrf | xfrm }\n"
+#else
-+ "where OBJECT := { link | address | route | rule | neigh | tunnel | maddress |\n"
-+ " mroute | mrule | monitor | netns | macsec | token | ila |\n"
-+ " vrf | sr }\n"
++ "where OBJECT := { address | ila | link | macsec | maddress | monitor |\n"
++ " mroute | mrule | neighbor | neighbour | netns | route |\n"
++ " rule | sr | token | tunnel | vrf }\n"
+#endif
" OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
" -h[uman-readable] | -iec | -j[son] | -p[retty] |\n"
diff --git a/package/network/utils/iproute2/patches/185-libbpf-add-limits-h.patch b/package/network/utils/iproute2/patches/185-libbpf-add-limits-h.patch
deleted file mode 100644
index 07dbbc65b9..0000000000
--- a/package/network/utils/iproute2/patches/185-libbpf-add-limits-h.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From c77310119f9a5f99221dd967c5eb0c7a26094b41 Mon Sep 17 00:00:00 2001
-From: Tony Ambardar <Tony.Ambardar@gmail.com>
-Date: Wed, 3 Mar 2021 10:29:24 -0800
-Subject: [PATCH] lib/bpf: add missing limits.h includes
-
-Several functions in bpf_glue.c and bpf_libbpf.c rely on PATH_MAX, which is
-normally included from <limits.h> in other iproute2 source files.
-
-It fixes errors seen using gcc 10.2.0, binutils 2.35.1 and musl 1.1.24:
-
-bpf_glue.c: In function 'get_libbpf_version':
-bpf_glue.c:46:11: error: 'PATH_MAX' undeclared (first use in this function);
-did you mean 'AF_MAX'?
- 46 | char buf[PATH_MAX], *s;
- | ^~~~~~~~
- | AF_MAX
-
-Reported-by: Rui Salvaterra <rsalvaterra@gmail.com>
-Signed-off-by: Tony Ambardar <Tony.Ambardar@gmail.com>
----
- lib/bpf_glue.c | 2 ++
- lib/bpf_libbpf.c | 1 +
- 2 files changed, 3 insertions(+)
-
---- a/lib/bpf_glue.c
-+++ b/lib/bpf_glue.c
-@@ -4,6 +4,8 @@
- * Authors: Hangbin Liu <haliu@redhat.com>
- *
- */
-+#include <limits.h>
-+
- #include "bpf_util.h"
- #ifdef HAVE_LIBBPF
- #include <bpf/bpf.h>
---- a/lib/bpf_libbpf.c
-+++ b/lib/bpf_libbpf.c
-@@ -13,6 +13,7 @@
- #include <stdint.h>
- #include <errno.h>
- #include <fcntl.h>
-+#include <limits.h>
-
- #include <libelf.h>
- #include <gelf.h>