aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-01-24 13:51:45 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-01-24 13:53:34 +0100
commit95ab18e0124e8b409e4fc9d24cbf1729cd7c6f05 (patch)
treeb737eeb061def504c48a7fe5f6ce6e14fb666b06 /package/network
parent4d001af7c56e9c70d3e0bdba8db359e870c1faa4 (diff)
downloadupstream-95ab18e0124e8b409e4fc9d24cbf1729cd7c6f05.tar.gz
upstream-95ab18e0124e8b409e4fc9d24cbf1729cd7c6f05.tar.bz2
upstream-95ab18e0124e8b409e4fc9d24cbf1729cd7c6f05.zip
vxlan: add options to enable and disable UDP checksums
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/config/vxlan/Makefile2
-rwxr-xr-xpackage/network/config/vxlan/files/vxlan.sh6
2 files changed, 5 insertions, 3 deletions
diff --git a/package/network/config/vxlan/Makefile b/package/network/config/vxlan/Makefile
index a471d4e90c..aeceb9cd88 100644
--- a/package/network/config/vxlan/Makefile
+++ b/package/network/config/vxlan/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=vxlan
-PKG_VERSION:=1
+PKG_VERSION:=2
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/config/vxlan/files/vxlan.sh b/package/network/config/vxlan/files/vxlan.sh
index 27ccd8f127..d055d41edc 100755
--- a/package/network/config/vxlan/files/vxlan.sh
+++ b/package/network/config/vxlan/files/vxlan.sh
@@ -15,8 +15,8 @@ vxlan_generic_setup() {
local link="$cfg"
- local port vid ttl tos mtu macaddr zone
- json_get_vars port vid ttl tos mtu macaddr zone
+ local port vid ttl tos mtu macaddr zone rxcsum txcsum
+ json_get_vars port vid ttl tos mtu macaddr zone rxcsum txcsum
proto_init_update "$link" 1
@@ -36,6 +36,8 @@ vxlan_generic_setup() {
[ -n "$port" ] && json_add_int port "$port"
[ -n "$vid" ] && json_add_int id "$vid"
[ -n "$macaddr" ] && json_add_string macaddr "$macaddr"
+ [ -n "$rxcsum" ] && json_add_boolean rxcsum "$rxcsum"
+ [ -n "$txcsum" ] && json_add_boolean txcsum "$txcsum"
json_close_object
proto_close_tunnel