aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2017-05-13 13:41:30 +0200
committerJohn Crispin <john@phrozen.org>2017-05-16 16:58:15 +0200
commit89807b627f2e006eafe3395d6d98574a66d8c147 (patch)
treea91b5d8de805fceeb8d835fb93cc8bd70adc3eab /package/network
parent4b0a2ca9a47ce30f08161b5b12991f15d590938c (diff)
downloadupstream-89807b627f2e006eafe3395d6d98574a66d8c147.tar.gz
upstream-89807b627f2e006eafe3395d6d98574a66d8c147.tar.bz2
upstream-89807b627f2e006eafe3395d6d98574a66d8c147.zip
network/utils/curl: Update to 7.54.0
Update curl to 7.54.0 Update and fresh patches Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/curl/Makefile4
-rw-r--r--package/network/utils/curl/patches/200-no_docs_tests.patch26
-rw-r--r--package/network/utils/curl/patches/310-mbedtls-disable-runtime-version-check.patch2
3 files changed, 16 insertions, 16 deletions
diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index a5f842dc9f..c7361a36bc 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=curl
-PKG_VERSION:=7.53.1
+PKG_VERSION:=7.54.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
http://curl.mirror.anstey.ca/ \
http://curl.askapache.com/download/ \
https://curl.haxx.se/download/
-PKG_HASH:=1c7207c06d75e9136a944a2e0528337ce76f15b9ec9ae4bb30d703b59bf530e8
+PKG_HASH:=f50ebaf43c507fa7cc32be4b8108fa8bbd0f5022e90794388f3c7694a302ff06
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYING
diff --git a/package/network/utils/curl/patches/200-no_docs_tests.patch b/package/network/utils/curl/patches/200-no_docs_tests.patch
index 2fbcf59a41..0f7198bc6d 100644
--- a/package/network/utils/curl/patches/200-no_docs_tests.patch
+++ b/package/network/utils/curl/patches/200-no_docs_tests.patch
@@ -1,22 +1,22 @@
--- a/Makefile.am
+++ b/Makefile.am
-@@ -152,7 +152,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
+@@ -154,8 +154,8 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
+
bin_SCRIPTS = curl-config
- SUBDIRS = lib src include
--DIST_SUBDIRS = $(SUBDIRS) tests packages docs scripts
+-SUBDIRS = lib docs src include
+-DIST_SUBDIRS = $(SUBDIRS) tests packages scripts
++SUBDIRS = lib src include
+DIST_SUBDIRS = $(SUBDIRS) packages
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libcurl.pc
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -612,7 +612,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
+@@ -272,7 +272,7 @@ cygwinbin:
+ # We extend the standard install with a custom hook:
+ install-data-hook:
+ cd include && $(MAKE) install
+- cd docs && $(MAKE) install
++# cd docs && $(MAKE) install
- bin_SCRIPTS = curl-config
- SUBDIRS = lib src include
--DIST_SUBDIRS = $(SUBDIRS) tests packages docs scripts
-+DIST_SUBDIRS = $(SUBDIRS) packages
- pkgconfigdir = $(libdir)/pkgconfig
- pkgconfig_DATA = libcurl.pc
- LIB_VAUTH_CFILES = vauth/vauth.c vauth/cleartext.c vauth/cram.c \
+ # We extend the standard uninstall with a custom hook:
+ uninstall-hook:
diff --git a/package/network/utils/curl/patches/310-mbedtls-disable-runtime-version-check.patch b/package/network/utils/curl/patches/310-mbedtls-disable-runtime-version-check.patch
index 89e057eb91..02b7e8d3d8 100644
--- a/package/network/utils/curl/patches/310-mbedtls-disable-runtime-version-check.patch
+++ b/package/network/utils/curl/patches/310-mbedtls-disable-runtime-version-check.patch
@@ -1,6 +1,6 @@
--- a/lib/vtls/mbedtls.c
+++ b/lib/vtls/mbedtls.c
-@@ -729,7 +729,7 @@ void Curl_mbedtls_session_free(void *ptr
+@@ -791,7 +791,7 @@ void Curl_mbedtls_session_free(void *ptr
size_t Curl_mbedtls_version(char *buffer, size_t size)
{