aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorDario Ernst <Dario.Ernst@riverbed.com>2016-11-29 16:02:48 +0100
committerJohn Crispin <john@phrozen.org>2016-12-14 10:37:01 +0100
commit866b7bad00833ed2be9bf571b68c6d5e8034bc12 (patch)
treeef19e4325bd6a03fb723f93ccfd90d6087b482b2 /package/network
parent132b88ea3975fb512ba9cece87ead5576d979e05 (diff)
downloadupstream-866b7bad00833ed2be9bf571b68c6d5e8034bc12.tar.gz
upstream-866b7bad00833ed2be9bf571b68c6d5e8034bc12.tar.bz2
upstream-866b7bad00833ed2be9bf571b68c6d5e8034bc12.zip
dropbear: clean up default PATH handling in makefile
Harmonise handling of DEFAULT_PATH by removing the patch introducing #ifndef guards around the path, and only using one means to set the path in the makefile. Signed-off-by: Dario Ernst <Dario.Ernst@riverbed.com>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/dropbear/Makefile4
-rw-r--r--package/network/services/dropbear/patches/500-set-default-path.patch12
2 files changed, 2 insertions, 14 deletions
diff --git a/package/network/services/dropbear/Makefile b/package/network/services/dropbear/Makefile
index 41c66dd43c..faad41adf2 100644
--- a/package/network/services/dropbear/Makefile
+++ b/package/network/services/dropbear/Makefile
@@ -77,13 +77,13 @@ CONFIGURE_ARGS += \
--disable-zlib \
--enable-bundled-libtom
-TARGET_CFLAGS += -DDEFAULT_PATH=\\\"$(CONFIG_TARGET_INIT_PATH)\\\" -DARGTYPE=3 -ffunction-sections -fdata-sections
+TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections
define Build/Configure
$(Build/Configure/Default)
- $(SED) 's,^#define DEFAULT_PATH .*$$$$,#define DEFAULT_PATH "$(CONFIG_TARGET_INIT_PATH)",g' \
+ $(SED) 's,^#define DEFAULT_PATH .*$$$$,#define DEFAULT_PATH "$(TARGET_INIT_PATH)",g' \
$(PKG_BUILD_DIR)/options.h
awk 'BEGIN { rc = 1 } \
diff --git a/package/network/services/dropbear/patches/500-set-default-path.patch b/package/network/services/dropbear/patches/500-set-default-path.patch
deleted file mode 100644
index da6b9ae0ce..0000000000
--- a/package/network/services/dropbear/patches/500-set-default-path.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/options.h
-+++ b/options.h
-@@ -352,7 +352,9 @@ be overridden at runtime with -I. 0 disa
- #define DEFAULT_IDLE_TIMEOUT 0
-
- /* The default path. This will often get replaced by the shell */
-+#ifndef DEFAULT_PATH
- #define DEFAULT_PATH "/usr/bin:/bin"
-+#endif
-
- /* Some other defines (that mostly should be left alone) are defined
- * in sysoptions.h */