aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2020-09-25 10:28:19 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2020-09-25 10:31:36 +0800
commit7dc78d1d2893b672544e8c26026ce961a7248a82 (patch)
treef8b2093a1f8e92f14c1621046e83ba61a048d09b /package/network
parentd20007ce91e25385d792faedc3146cbfdc34a8c5 (diff)
downloadupstream-7dc78d1d2893b672544e8c26026ce961a7248a82.tar.gz
upstream-7dc78d1d2893b672544e8c26026ce961a7248a82.tar.bz2
upstream-7dc78d1d2893b672544e8c26026ce961a7248a82.zip
dnsmasq: fix handling ignore condition for dnssec
It should return false to indicate that the option should not be ignored Fixes 064dc1e8 ("dnsmasq: abort when dnssec requested but not available") Reported-by: Sami Olmari <sami@olmari.fi> Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/dnsmasq/Makefile2
-rw-r--r--package/network/services/dnsmasq/files/dnsmasq.init1
2 files changed, 2 insertions, 1 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index b5f2e78fd2..fe68378f48 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_UPSTREAM_VERSION:=2.82
PKG_VERSION:=$(subst test,~~test,$(subst rc,~rc,$(PKG_UPSTREAM_VERSION)))
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_UPSTREAM_VERSION).tar.xz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
diff --git a/package/network/services/dnsmasq/files/dnsmasq.init b/package/network/services/dnsmasq/files/dnsmasq.init
index d387c90285..0fa3074f92 100644
--- a/package/network/services/dnsmasq/files/dnsmasq.init
+++ b/package/network/services/dnsmasq/files/dnsmasq.init
@@ -48,6 +48,7 @@ dnsmasq_ignore_opt() {
echo "dnsmasq: \"$opt\" requested, but dnssec support is not available" >&2
exit 1
fi
+ return 1
;;
tftp-*)
[ -z "$dnsmasq_has_tftp" ] ;;