aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorJason A. Donenfeld <Jason@zx2c4.com>2019-07-02 14:42:50 +0200
committerHans Dedecker <dedeckeh@gmail.com>2019-07-02 22:06:42 +0200
commit7c23f741e97f6645bb5cd662a4943796a344b26a (patch)
tree1e57eb68ab7ce2f224b0c380a1bdc4bf27bba230 /package/network
parent299f6cb2da0a443484339aaa51b3d9edcc21ce4e (diff)
downloadupstream-7c23f741e97f6645bb5cd662a4943796a344b26a.tar.gz
upstream-7c23f741e97f6645bb5cd662a4943796a344b26a.tar.bz2
upstream-7c23f741e97f6645bb5cd662a4943796a344b26a.zip
wireguard: bump to 0.0.20190702
* curve25519: not all linkers support bmi2 and adx This should allow WireGuard to build on older toolchains. * global: switch to coarse ktime Our prior use of fast ktime before meant that sometimes, depending on how broken the motherboard was, we'd wind up calling into the HPET slow path. Here we move to coarse ktime which is always super speedy. In the process we had to fix the resolution of the clock, as well as introduce a new interface for it, landing in 5.3. Older kernels fall back to a fast-enough mechanism based on jiffies. https://lore.kernel.org/lkml/tip-e3ff9c3678b4d80e22d2557b68726174578eaf52@git.kernel.org/ https://lore.kernel.org/lkml/20190621203249.3909-3-Jason@zx2c4.com/ * netlink: cast struct over cb->args for type safety This follow recent upstream changes such as: https://lore.kernel.org/lkml/20190628144022.31376-1-Jason@zx2c4.com/ * peer: use LIST_HEAD macro Style nit. * receive: queue dead packets to napi queue instead of empty rx_queue This mitigates a WARN_ON being triggered by the workqueue code. It was quite hard to trigger, except sporadically, or reliably with a PC Engines ALIX, an extremely slow board with an AMD LX800 that Ryan Whelan of Axatrax was kind enough to mail me. Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/wireguard/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/services/wireguard/Makefile b/package/network/services/wireguard/Makefile
index 310d5599c2..0516769422 100644
--- a/package/network/services/wireguard/Makefile
+++ b/package/network/services/wireguard/Makefile
@@ -11,12 +11,12 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=wireguard
-PKG_VERSION:=0.0.20190601
+PKG_VERSION:=0.0.20190702
PKG_RELEASE:=1
PKG_SOURCE:=WireGuard-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://git.zx2c4.com/WireGuard/snapshot/
-PKG_HASH:=7528461824a0174bd7d4f15e68d8f0ce9a8ea318411502b80759438e8ef65568
+PKG_HASH:=1a1311bc71abd47a72c47d918be3bacc486b3de90734661858af75cc990dbaac
PKG_LICENSE:=GPL-2.0 Apache-2.0
PKG_LICENSE_FILES:=COPYING