aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2018-12-09 19:34:05 +0000
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2018-12-10 09:14:06 +0000
commit7b083bbb825029ef8dd72c676a1eabae61627573 (patch)
treea0eb32c16097721ef67ce161fddc7f4c27df71cb /package/network
parent99dbbe7eb735081e0595f43ae2c69ef4792d4cea (diff)
downloadupstream-7b083bbb825029ef8dd72c676a1eabae61627573.tar.gz
upstream-7b083bbb825029ef8dd72c676a1eabae61627573.tar.bz2
upstream-7b083bbb825029ef8dd72c676a1eabae61627573.zip
dnsmasq: drop dnssec timestamp file patch
Openwrt no longer uses and has not used since 5acfe55d71 Jun 2016 the timestamp file (/etc/dnsmasq.time) method of resolving the dnssec/ntp dnslookup chicken/egg problem, having used signals from ntp since that change. Drop the 'dnssec-improve-timestamp-heuristic' patch since it is neither used nor sent upstream. One less thing to refresh & maintain. Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/dnsmasq/Makefile2
-rw-r--r--package/network/services/dnsmasq/patches/210-dnssec-improve-timestamp-heuristic.patch47
2 files changed, 1 insertions, 48 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index 59f5fb6158..10537d711f 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_VERSION:=2.80
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
diff --git a/package/network/services/dnsmasq/patches/210-dnssec-improve-timestamp-heuristic.patch b/package/network/services/dnsmasq/patches/210-dnssec-improve-timestamp-heuristic.patch
deleted file mode 100644
index be1195abbd..0000000000
--- a/package/network/services/dnsmasq/patches/210-dnssec-improve-timestamp-heuristic.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 79e60e145f8a595bca5a784c00b437216d51de68 Mon Sep 17 00:00:00 2001
-From: Steven Barth <steven@midlink.org>
-Date: Mon, 13 Apr 2015 09:45:20 +0200
-Subject: [PATCH] dnssec: improve timestamp heuristic
-
-Signed-off-by: Steven Barth <steven@midlink.org>
----
- src/dnssec.c | 15 +++++++++++----
- 1 file changed, 11 insertions(+), 4 deletions(-)
-
---- a/src/dnssec.c
-+++ b/src/dnssec.c
-@@ -143,17 +143,24 @@ static time_t timestamp_time;
- int setup_timestamp(void)
- {
- struct stat statbuf;
-+ time_t now;
-+ time_t base = 1420070400; /* 1-1-2015 */
-
- daemon->back_to_the_future = 0;
-
- if (!daemon->timestamp_file)
- return 0;
-+
-+ now = time(NULL);
-+
-+ if (!stat("/proc/self/exe", &statbuf) && difftime(statbuf.st_mtime, base) > 0)
-+ base = statbuf.st_mtime;
-
- if (stat(daemon->timestamp_file, &statbuf) != -1)
- {
- timestamp_time = statbuf.st_mtime;
- check_and_exit:
-- if (difftime(timestamp_time, time(0)) <= 0)
-+ if (difftime(now, base) >= 0 && difftime(timestamp_time, now) <= 0)
- {
- /* time already OK, update timestamp, and do key checking from the start. */
- if (utimes(daemon->timestamp_file, NULL) == -1)
-@@ -174,7 +181,7 @@ int setup_timestamp(void)
-
- close(fd);
-
-- timestamp_time = 1420070400; /* 1-1-2015 */
-+ timestamp_time = base; /* 1-1-2015 */
- tv[0].tv_sec = tv[1].tv_sec = timestamp_time;
- tv[0].tv_usec = tv[1].tv_usec = 0;
- if (utimes(daemon->timestamp_file, tv) == 0)