aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2013-10-07 08:43:33 +0000
committerSteven Barth <cyrus@openwrt.org>2013-10-07 08:43:33 +0000
commit6dbfe226011f3e76eb76037f14f2b9cf53402b15 (patch)
tree15686ecfc34c7dd824013489c56e1892c61f1e9b /package/network
parent702936f4c981e479bbc1bcd8b516b37a6767551d (diff)
downloadupstream-6dbfe226011f3e76eb76037f14f2b9cf53402b15.tar.gz
upstream-6dbfe226011f3e76eb76037f14f2b9cf53402b15.tar.bz2
upstream-6dbfe226011f3e76eb76037f14f2b9cf53402b15.zip
odhcp6c: improve server selection, introduce "forceprefix" option
SVN-Revision: 38314
Diffstat (limited to 'package/network')
-rw-r--r--package/network/ipv6/odhcp6c/Makefile4
-rwxr-xr-xpackage/network/ipv6/odhcp6c/files/dhcpv6.sh7
2 files changed, 7 insertions, 4 deletions
diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index d6540d6e30..22e39bde4f 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-10-02
+PKG_VERSION:=2013-10-07
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=357ecc1f5163bc7f74c64f4bca387e8d44a2eac5
+PKG_SOURCE_VERSION:=d2c90000292f62962276579fa6b2eac1ff4b76e6
PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/odhcp6c/files/dhcpv6.sh b/package/network/ipv6/odhcp6c/files/dhcpv6.sh
index bf6cd9aa62..ab344e1d30 100755
--- a/package/network/ipv6/odhcp6c/files/dhcpv6.sh
+++ b/package/network/ipv6/odhcp6c/files/dhcpv6.sh
@@ -10,6 +10,7 @@ proto_dhcpv6_init_config() {
proto_config_add_string "clientid"
proto_config_add_string "reqopts"
proto_config_add_string "noslaaconly"
+ proto_config_add_string "forceprefix"
proto_config_add_string "norelease"
proto_config_add_string "ip6prefix"
proto_config_add_string "iface_dslite"
@@ -20,8 +21,8 @@ proto_dhcpv6_setup() {
local config="$1"
local iface="$2"
- local reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite ifaceid
- json_get_vars reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite ifaceid
+ local reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid
+ json_get_vars reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid
# Configure
@@ -35,6 +36,8 @@ proto_dhcpv6_setup() {
[ "$noslaaconly" = "1" ] && append opts "-S"
+ [ "$forceprefix" = "1" ] && append opts "-F"
+
[ "$norelease" = "1" ] && append opts "-k"
[ -n "$ifaceid" ] && append opts "-i$ifaceid"