aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-08-27 12:43:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-08-27 12:43:22 +0000
commit5da52afa79319c7fbac683d6a3d13411284a622a (patch)
treeaa0e1ab6034ff453111d398e47cb7458972cd401 /package/network
parent2cd72294b629f0075bb38f4401ab3b91c539470c (diff)
downloadupstream-5da52afa79319c7fbac683d6a3d13411284a622a.tar.gz
upstream-5da52afa79319c7fbac683d6a3d13411284a622a.tar.bz2
upstream-5da52afa79319c7fbac683d6a3d13411284a622a.zip
hostapd: properly enable 802.11w support
Add CONFIG_IEEE80211W variable to DRIVER_MAKEOPTS so that 802.11w support is properly compiled in full variant. This fixes #20179 Signed-off-by: Janusz Dziemidowicz <rraptorr@nails.eu.org> SVN-Revision: 46737
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/hostapd/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 3dff7b4852..c16cb11294 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -71,7 +71,7 @@ DRIVER_MAKEOPTS= \
CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
ifeq ($(LOCAL_VARIANT),full)
- CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
+ DRIVER_MAKEOPTS += CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
endif
ifneq ($(LOCAL_TYPE),hostapd)