aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-11 16:41:58 +0000
committerJohn Crispin <john@openwrt.org>2015-03-11 16:41:58 +0000
commit5b04e0dc4e257f8db6d8174930f46150cd25749b (patch)
tree96ab776aeef7229b3519f1561ce3e74402e89cf2 /package/network
parenta67cd94def366c1f3a7c997dbe96697816ad32c4 (diff)
downloadupstream-5b04e0dc4e257f8db6d8174930f46150cd25749b.tar.gz
upstream-5b04e0dc4e257f8db6d8174930f46150cd25749b.tar.bz2
upstream-5b04e0dc4e257f8db6d8174930f46150cd25749b.zip
ipset: Bump to 6.24
Included you'll find a patch to bump ipset to version 6.24. This version supports the ip,fwmark set, which is needed for mwan3 1.6. Signed-off-by: Jeroen Louwes <jeroen.louwes@gmail.com> SVN-Revision: 44671
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/ipset/Makefile4
-rw-r--r--package/network/utils/ipset/patches/001-timeout-size.patch28
2 files changed, 2 insertions, 30 deletions
diff --git a/package/network/utils/ipset/Makefile b/package/network/utils/ipset/Makefile
index 4afcae5d49..9a8f3461d9 100644
--- a/package/network/utils/ipset/Makefile
+++ b/package/network/utils/ipset/Makefile
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ipset
-PKG_VERSION:=6.20.1
+PKG_VERSION:=6.24
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://ipset.netfilter.org
-PKG_MD5SUM:=8af741492752fbf24d3a28a9d1473d40
+PKG_MD5SUM:=8831b8f01458bf2abacc222884195a62
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
PKG_LICENSE:=GPL-2.0
diff --git a/package/network/utils/ipset/patches/001-timeout-size.patch b/package/network/utils/ipset/patches/001-timeout-size.patch
deleted file mode 100644
index b9ff4e256d..0000000000
--- a/package/network/utils/ipset/patches/001-timeout-size.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/lib/parse.c b/lib/parse.c
-index 8ea8542..440ef8f 100644
---- a/lib/parse.c
-+++ b/lib/parse.c
-@@ -1292,15 +1292,20 @@ ipset_parse_timeout(struct ipset_session *session,
- enum ipset_opt opt, const char *str)
- {
- int err;
-- unsigned long long num = 0;
-+ unsigned long long llnum = 0;
-+ uint32_t num = 0;
-
- assert(session);
- assert(opt == IPSET_OPT_TIMEOUT);
- assert(str);
-
-- err = string_to_number_ll(session, str, 0, UINT_MAX/1000, &num);
-- if (err == 0)
-+ err = string_to_number_ll(session, str, 0, UINT_MAX/1000, &llnum);
-+ if (err == 0) {
-+ /* Timeout is expected to be 32bits wide, so we have
-+ to convert it here */
-+ num = llnum;
- return ipset_session_data_set(session, opt, &num);
-+ }
-
- return err;
- }