aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2021-05-26 22:23:35 +0200
committerDavid Bauer <mail@david-bauer.net>2021-05-26 23:12:09 +0200
commit553cc47ec75ee15ff51fde714a75403450bac730 (patch)
tree702837a3b3353257a2fe73a6913af3de16b64d2b /package/network
parent862bc9f59779afe06d7279e2534843dbcccd9c2c (diff)
downloadupstream-553cc47ec75ee15ff51fde714a75403450bac730.tar.gz
upstream-553cc47ec75ee15ff51fde714a75403450bac730.tar.bz2
upstream-553cc47ec75ee15ff51fde714a75403450bac730.zip
hostapd: ACS: fix channel 100 frequency
Channel 100 is a valid channel to choose for 80MHz operation. However, it's assigned to 5500 MHz, not 5550MHz. In fact, there is no channel assigned to this frequency. Fix this obbvious typo to allow ACS to select channel 100 for 80 MHz operation again. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/patches/720-ACS-fix-channel-100-frequency.patch30
2 files changed, 31 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index ca6cc026c1..05a35d3751 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=33
+PKG_RELEASE:=34
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/patches/720-ACS-fix-channel-100-frequency.patch b/package/network/services/hostapd/patches/720-ACS-fix-channel-100-frequency.patch
new file mode 100644
index 0000000000..3ef19e5298
--- /dev/null
+++ b/package/network/services/hostapd/patches/720-ACS-fix-channel-100-frequency.patch
@@ -0,0 +1,30 @@
+From 5a24286ed6315e1fef755ca1970792554f59b1fc Mon Sep 17 00:00:00 2001
+From: David Bauer <mail@david-bauer.net>
+Date: Wed, 26 May 2021 22:15:35 +0200
+Subject: [PATCH] ACS: fix channel 100 frequency
+
+Channel 100 is a valid channel to choose for 80MHz operation. However,
+it's assigned to 5500 MHz, not 5550MHz. In fact, there is no channel
+assigned to this frequency.
+
+Fix this obbvious typo to allow ACS to select channel 100 for 80 MHz
+operation again.
+
+Fixes commit bef5eee4f7b2 ("Convert channel to frequency based selection for AP mode ACS")
+
+Signed-off-by: David Bauer <mail@david-bauer.net>
+---
+ src/ap/acs.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/src/ap/acs.c
++++ b/src/ap/acs.c
+@@ -386,7 +386,7 @@ static int acs_usable_bw40_chan(const st
+
+ static int acs_usable_bw80_chan(const struct hostapd_channel_data *chan)
+ {
+- const int allowed[] = { 5180, 5260, 5550, 5580, 5660, 5745, 5955, 6035,
++ const int allowed[] = { 5180, 5260, 5500, 5580, 5660, 5745, 5955, 6035,
+ 6115, 6195, 6275, 6355, 6435, 6515, 6595, 6675,
+ 6755, 6835, 6915, 6995 };
+ unsigned int i;