aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-12-06 13:12:06 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-12-16 00:57:19 +0100
commit1e98d985bbefa522fca29d3e74cdc9fe513b66a5 (patch)
treeac16473b24d8ae5b5c9d4067a8bed784cbacbd6d /package/network
parentd2b16a59d567135c683cd28906de6086e40ec880 (diff)
downloadupstream-1e98d985bbefa522fca29d3e74cdc9fe513b66a5.tar.gz
upstream-1e98d985bbefa522fca29d3e74cdc9fe513b66a5.tar.bz2
upstream-1e98d985bbefa522fca29d3e74cdc9fe513b66a5.zip
swconfig: Add missing include
Fixes these warnings: swlib.c:455:18: warning: implicit declaration of function 'isspace' swlib.c:461:9: warning: implicit declaration of function 'isdigit' Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/config/swconfig/Makefile2
-rw-r--r--package/network/config/swconfig/src/swlib.c1
2 files changed, 2 insertions, 1 deletions
diff --git a/package/network/config/swconfig/Makefile b/package/network/config/swconfig/Makefile
index e457ce4882..8b1d6cd64a 100644
--- a/package/network/config/swconfig/Makefile
+++ b/package/network/config/swconfig/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=swconfig
-PKG_RELEASE:=11
+PKG_RELEASE:=12
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=GPL-2.0
diff --git a/package/network/config/swconfig/src/swlib.c b/package/network/config/swconfig/src/swlib.c
index 0fb8ebb392..0e09a1505b 100644
--- a/package/network/config/swconfig/src/swlib.c
+++ b/package/network/config/swconfig/src/swlib.c
@@ -16,6 +16,7 @@
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
+#include <ctype.h>
#include <inttypes.h>
#include <errno.h>
#include <stdint.h>