aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-01-02 01:01:33 +0100
committerMathias Kresin <dev@kresin.me>2018-02-20 19:25:17 +0100
commit04cb1e0fd20196e2e6ec5f8864f5d694f134cbc1 (patch)
treea1f243a8b73e3f3670080a3e93b4d1c3f32c569a /package/network
parent97c27f01be995661a78424228917e16d9f6befde (diff)
downloadupstream-04cb1e0fd20196e2e6ec5f8864f5d694f134cbc1.tar.gz
upstream-04cb1e0fd20196e2e6ec5f8864f5d694f134cbc1.tar.bz2
upstream-04cb1e0fd20196e2e6ec5f8864f5d694f134cbc1.zip
ppp: fix build with kernel 4.14.9+
With a9772285a724 ("linux/compiler.h: Split into compiler.h and compiler_types.h") compiler.h was refactored and most its content was moved to compiler_types.h. Both files are required to build ppp-mod-pppoa. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/ppp/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/network/services/ppp/Makefile b/package/network/services/ppp/Makefile
index 0614ebc58b..beeaa53c22 100644
--- a/package/network/services/ppp/Makefile
+++ b/package/network/services/ppp/Makefile
@@ -178,10 +178,15 @@ $(call Build/Configure/Default,, \
UNAME_M="$(ARCH)" \
)
mkdir -p $(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux
- cp \
+ $(CP) \
$(LINUX_DIR)/include/linux/compiler.h \
$(LINUX_DIR)/include/$(LINUX_UAPI_DIR)linux/atm*.h \
$(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux/
+
+ # Kernel 4.14.9+ only, ignore the exit status of cp in case the file
+ # doesn't exits
+ -$(CP) $(LINUX_DIR)/include/linux/compiler_types.h \
+ $(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux/
endef
TARGET_CFLAGS += -ffunction-sections -fdata-sections