aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2018-09-14 21:52:39 +0100
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2018-09-15 08:46:32 +0100
commit033f02b9b5580e67e2f1b623f62da60d645e7ba2 (patch)
tree7be81a420036ee5f602123c77b136218531b93c3 /package/network
parent4a3298c124787721be632f15b77def945f097441 (diff)
downloadupstream-033f02b9b5580e67e2f1b623f62da60d645e7ba2.tar.gz
upstream-033f02b9b5580e67e2f1b623f62da60d645e7ba2.tar.bz2
upstream-033f02b9b5580e67e2f1b623f62da60d645e7ba2.zip
iproute2: q_cake: Also print nonat, nowash and no-ack-filter keywords
Pull in latest upstream tweaks: Similar to the previous patch for no-split-gso, the negative keywords for 'nat', 'wash' and 'ack-filter' were not printed either. Add those as well. Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/iproute2/Makefile2
-rw-r--r--package/network/utils/iproute2/patches/190-add-cake-to-tc.patch8
2 files changed, 7 insertions, 3 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 5ed9556043..1c8e3e66d6 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
PKG_VERSION:=4.18.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
diff --git a/package/network/utils/iproute2/patches/190-add-cake-to-tc.patch b/package/network/utils/iproute2/patches/190-add-cake-to-tc.patch
index f61168c696..a05d8776ee 100644
--- a/package/network/utils/iproute2/patches/190-add-cake-to-tc.patch
+++ b/package/network/utils/iproute2/patches/190-add-cake-to-tc.patch
@@ -854,7 +854,7 @@
TCMODULES += e_bpf.o
--- /dev/null
+++ b/tc/q_cake.c
-@@ -0,0 +1,801 @@
+@@ -0,0 +1,805 @@
+// SPDX-License-Identifier: GPL-2.0 OR BSD-3-Clause
+
+/*
@@ -1325,6 +1325,8 @@
+
+ if (nat)
+ print_string(PRINT_FP, NULL, "nat ", NULL);
++ else
++ print_string(PRINT_FP, NULL, "nonat ", NULL);
+ print_bool(PRINT_JSON, "nat", NULL, nat);
+
+ if (tb[TCA_CAKE_WASH] &&
@@ -1365,6 +1367,8 @@
+
+ if (wash)
+ print_string(PRINT_FP, NULL, "wash ", NULL);
++ else
++ print_string(PRINT_FP, NULL, "nowash ", NULL);
+ print_bool(PRINT_JSON, "wash", NULL, wash);
+
+ if (ingress)
@@ -1377,7 +1381,7 @@
+ else if (ack_filter == CAKE_ACK_FILTER)
+ print_string(PRINT_ANY, "ack-filter", "ack-filter ", "enabled");
+ else
-+ print_string(PRINT_JSON, "ack-filter", NULL, "disabled");
++ print_string(PRINT_ANY, "ack-filter", "no-ack-filter ", "disabled");
+
+ if (split_gso)
+ print_string(PRINT_FP, NULL, "split-gso ", NULL);