aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2021-04-10 17:40:21 -0700
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2021-04-24 12:21:40 +0100
commitaabc6320233f700f303e3e5d0adbba2cfe9ac2d9 (patch)
treecccd05a245b60c37c9ae41babde4c9098fc6171f /package/network/utils
parentcf20f1bb5f0479c2509dd651d08e235a3b9e8755 (diff)
downloadupstream-aabc6320233f700f303e3e5d0adbba2cfe9ac2d9.tar.gz
upstream-aabc6320233f700f303e3e5d0adbba2cfe9ac2d9.tar.bz2
upstream-aabc6320233f700f303e3e5d0adbba2cfe9ac2d9.zip
bpftools: update to v5.11.16, simplify make
Update to the latest stable upstream version. Drop unneeded make variables to remove redundant assignments seen during invocation of package Makefile. Also remove the following patch now included upstream: * 200-fix-install-param-order-on-macos.patch Compile and run-tested on malta/mips32be, using bpftool directly and also libbpf (linked with tc) to inspect and load simple eBPF programs. Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'package/network/utils')
-rw-r--r--package/network/utils/bpftools/Makefile12
-rw-r--r--package/network/utils/bpftools/patches/200-fix-install-param-order-on-macos.patch11
2 files changed, 7 insertions, 16 deletions
diff --git a/package/network/utils/bpftools/Makefile b/package/network/utils/bpftools/Makefile
index 52963e4148..f044cc81f8 100644
--- a/package/network/utils/bpftools/Makefile
+++ b/package/network/utils/bpftools/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bpftools
-PKG_VERSION:=5.11.2
-PKG_RELEASE:=2
+PKG_VERSION:=5.11.16
+PKG_RELEASE:=1
PKG_SOURCE:=linux-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/kernel/v5.x
-PKG_HASH:=904a5b3cbaf5264ef8da6c7a5445fa7ea19168ad77fb83a7cc1b8ba95d52d0a0
+PKG_HASH:=21163681d130cbce5a6be39019e2c69e44f284855ddd70b1a3bd039249540f43
PKG_MAINTAINER:=Tony Ambardar <itugrok@yahoo.com>
@@ -93,9 +93,11 @@ ifneq ($(BUILD_VARIANT),lib)
TARGET_LDFLAGS += -Wl,--gc-sections
endif
-MAKE_FLAGS += \
+MAKE_VARS = \
EXTRA_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
- LDFLAGS="$(TARGET_LDFLAGS)" \
+ LDFLAGS="$(TARGET_LDFLAGS)"
+
+MAKE_FLAGS += \
BPFTOOL_VERSION="$(LINUX_VERSION)" \
FEATURES_DUMP="$(PKG_BUILD_DIR)/FEATURE-DUMP.openwrt" \
OUTPUT="$(PKG_BUILD_DIR)/" \
diff --git a/package/network/utils/bpftools/patches/200-fix-install-param-order-on-macos.patch b/package/network/utils/bpftools/patches/200-fix-install-param-order-on-macos.patch
deleted file mode 100644
index ffb7e2ce52..0000000000
--- a/package/network/utils/bpftools/patches/200-fix-install-param-order-on-macos.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/tools/lib/bpf/Makefile
-+++ b/tools/lib/bpf/Makefile
-@@ -236,7 +236,7 @@ define do_install
- if [ ! -d '$(DESTDIR_SQ)$2' ]; then \
- $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$2'; \
- fi; \
-- $(INSTALL) $1 $(if $3,-m $3,) '$(DESTDIR_SQ)$2'
-+ $(INSTALL) $(if $3,-m $3,) $1 '$(DESTDIR_SQ)$2'
- endef
-
- install_lib: all_cmd