aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2020-08-23 10:47:04 +0200
committerHans Dedecker <dedeckeh@gmail.com>2020-08-23 11:03:40 +0200
commit4358373e6911b5ea0af4610ca89a9510ad39e5c1 (patch)
treead453dbb849c49c62fbba42692cbecc5d24efdff /package/network/utils
parentb52b4afa15bc854e4ff68e45cc5b84905d5e9a54 (diff)
downloadupstream-4358373e6911b5ea0af4610ca89a9510ad39e5c1.tar.gz
upstream-4358373e6911b5ea0af4610ca89a9510ad39e5c1.tar.bz2
upstream-4358373e6911b5ea0af4610ca89a9510ad39e5c1.zip
curl: disable zstd support
Fixes package libcurl build issue : Package libcurl is missing dependencies for the following libraries: libzstd.so.1 Suggested-by: Syrone Wong <wong.syrone@gmail.com> Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package/network/utils')
-rw-r--r--package/network/utils/curl/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index f53621a858..c70bfdff20 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=curl
PKG_VERSION:=7.72.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
@@ -118,6 +118,7 @@ CONFIGURE_ARGS += \
--without-libidn \
--without-ca-path \
--without-libpsl \
+ --without-zstd \
--with-ca-bundle=/etc/ssl/certs/ca-certificates.crt \
\
$(call autoconf_bool,CONFIG_IPV6,ipv6) \