aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/xtables-addons/Makefile
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-07-15 14:41:45 +0000
committerJonas Gorski <jogo@openwrt.org>2015-07-15 14:41:45 +0000
commit46a69e96a42c6d2e7542e27d3532a0804c3bcc82 (patch)
tree287cbf12376eaccf7009bfae8db7418c9b516c99 /package/network/utils/xtables-addons/Makefile
parentd4ff533bccc4000dcdf00dcbbffb77532f1650f2 (diff)
downloadupstream-46a69e96a42c6d2e7542e27d3532a0804c3bcc82.tar.gz
upstream-46a69e96a42c6d2e7542e27d3532a0804c3bcc82.tar.bz2
upstream-46a69e96a42c6d2e7542e27d3532a0804c3bcc82.zip
xtables-addons: update to 2.7 to fix compilation with 4.1
Also drop the configure (not .ac) patch part as autoreconf will overwrite it anyway with a newly generated version. Signed-off-by: Jonas Gorski <jogo@openwrt.org> Acked-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 46385
Diffstat (limited to 'package/network/utils/xtables-addons/Makefile')
-rw-r--r--package/network/utils/xtables-addons/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/network/utils/xtables-addons/Makefile b/package/network/utils/xtables-addons/Makefile
index cadeaff658..8f54ee3bb5 100644
--- a/package/network/utils/xtables-addons/Makefile
+++ b/package/network/utils/xtables-addons/Makefile
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=xtables-addons
-PKG_VERSION:=2.5
+PKG_VERSION:=2.7
PKG_RELEASE:=1
-PKG_MD5SUM:=335663ece5fb17c7d0bb24dbdc697eb1
+PKG_MD5SUM:=81bd7ba82e5f7bfd1458fc97ddf72e1d
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/xtables-addons
@@ -92,7 +92,7 @@ define BuildTemplate
define KernelPackage/ipt-$(1)
SUBMENU:=Netfilter Extensions
TITLE:=$(2) netfilter module
- DEPENDS:=+kmod-ipt-core @!LINUX_4_1 $(5)
+ DEPENDS:=+kmod-ipt-core $(5)
KCONFIG:=$(6)
FILES:=$(foreach mod,$(4),$(PKG_BUILD_DIR)/extensions/$(mod).$(LINUX_KMOD_SUFFIX))
AUTOLOAD:=$(call AutoProbe,$(notdir $(4)))