aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/umbim
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-09-11 12:26:41 +0000
committerJohn Crispin <john@openwrt.org>2014-09-11 12:26:41 +0000
commitc9d15fbd59f84355118987bbbbbad24d68c9b9bf (patch)
tree0a388bcea98a605658dd07a9deedc0f574c0f605 /package/network/utils/umbim
parent7bad68804c751fb81419fd4e6a1ab0f2e9c1836c (diff)
downloadupstream-c9d15fbd59f84355118987bbbbbad24d68c9b9bf.tar.gz
upstream-c9d15fbd59f84355118987bbbbbad24d68c9b9bf.tar.bz2
upstream-c9d15fbd59f84355118987bbbbbad24d68c9b9bf.zip
umbim: update to latest git
adds handling for username/password Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 42466
Diffstat (limited to 'package/network/utils/umbim')
-rw-r--r--package/network/utils/umbim/Makefile4
-rwxr-xr-xpackage/network/utils/umbim/files/lib/netifd/proto/mbim.sh8
2 files changed, 7 insertions, 5 deletions
diff --git a/package/network/utils/umbim/Makefile b/package/network/utils/umbim/Makefile
index f0868cebf8..b463a6de43 100644
--- a/package/network/utils/umbim/Makefile
+++ b/package/network/utils/umbim/Makefile
@@ -1,13 +1,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=umbim
-PKG_VERSION:=2014-08-26
+PKG_VERSION:=2014-09-09
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://git.openwrt.org/project/umbim.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=7741d88cdfd36f0c4380f660a9ad7109df76b432
+PKG_SOURCE_VERSION:=4ae19ab4fcdd70dbfc8c303d752502f2da5a7e75
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
diff --git a/package/network/utils/umbim/files/lib/netifd/proto/mbim.sh b/package/network/utils/umbim/files/lib/netifd/proto/mbim.sh
index c93ba331df..3cc7412e6b 100755
--- a/package/network/utils/umbim/files/lib/netifd/proto/mbim.sh
+++ b/package/network/utils/umbim/files/lib/netifd/proto/mbim.sh
@@ -11,6 +11,9 @@ proto_mbim_init_config() {
proto_config_add_string apn
proto_config_add_string pincode
proto_config_add_string delay
+ proto_config_add_string auth
+ proto_config_add_string username
+ proto_config_add_string password
}
proto_mbim_setup() {
@@ -19,7 +22,7 @@ proto_mbim_setup() {
local ret
local device apn pincode delay
- json_get_vars device apn pincode delay
+ json_get_vars device apn pincode delay auth username password
[ -n "$device" ] || {
logger -p daemon.err -t "mbim[$$]" "No control device specified"
@@ -40,7 +43,6 @@ proto_mbim_setup() {
return 1
}
-
[ -n "$delay" ] && sleep "$delay"
logger -p daemon.info -t "mbim[$$]" "Reading capabilities"
@@ -100,7 +102,7 @@ proto_mbim_setup() {
tid=$((tid + 1))
logger -p daemon.info -t "mbim[$$]" "Connect to network"
- while ! umbim $DBG -n -t $tid -d $device connect "$apn"; do
+ while ! umbim $DBG -n -t $tid -d $device connect "$apn" "$auth" "$username" "$password"; do
tid=$((tid + 1))
sleep 1;
done