aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/nftables/patches/001-examples-compile-with-make-check.patch
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2022-03-06 00:16:27 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-03-07 21:44:53 +0100
commitd71928c1e36ed0247b2b663ba05b109eb401718f (patch)
treec68e34d6dccce232994320af21b08d9764fea0f5 /package/network/utils/nftables/patches/001-examples-compile-with-make-check.patch
parentbaea8255e0c442c8edfdb8755d644b6e6ba687ba (diff)
downloadupstream-d71928c1e36ed0247b2b663ba05b109eb401718f.tar.gz
upstream-d71928c1e36ed0247b2b663ba05b109eb401718f.tar.bz2
upstream-d71928c1e36ed0247b2b663ba05b109eb401718f.zip
nftables: update to version 1.0.2
Changelog: https://lwn.net/ml/netdev/YhO5Pn+6+dgAgSd9@salvia/ Patches: removed: - 001-parser-allow-quoted-string-in-flowtable_expr_member: it is now part of upstream release [1] added: - 001-examples-compile-with-make-check.patch: backported from [2], it fixes: nft-json-file.c:3:10: fatal error: nftables/libnftables.h: No such file or directory 3 | #include <nftables/libnftables.h> | ^~~~~~~~~~~~~~~~~~~~~~~~ compilation terminated. [1] https://git.netfilter.org/nftables/commit/?h=v1.0.2&id=07af4429241c9832a613cb8620331ac54257d9df [2] https://git.netfilter.org/nftables/commit/?id=18a08fb7f0443f8bde83393bd6f69e23a04246b3 Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'package/network/utils/nftables/patches/001-examples-compile-with-make-check.patch')
-rw-r--r--package/network/utils/nftables/patches/001-examples-compile-with-make-check.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/package/network/utils/nftables/patches/001-examples-compile-with-make-check.patch b/package/network/utils/nftables/patches/001-examples-compile-with-make-check.patch
new file mode 100644
index 0000000000..6a4430d86f
--- /dev/null
+++ b/package/network/utils/nftables/patches/001-examples-compile-with-make-check.patch
@@ -0,0 +1,29 @@
+From 18a08fb7f0443f8bde83393bd6f69e23a04246b3 Mon Sep 17 00:00:00 2001
+From: Pablo Neira Ayuso <pablo@netfilter.org>
+Date: Tue, 22 Feb 2022 00:56:36 +0100
+Subject: examples: compile with `make check' and add AM_CPPFLAGS
+
+Compile examples via `make check' like libnftnl does. Use AM_CPPFLAGS to
+specify local headers via -I.
+
+Unfortunately, `make distcheck' did not catch this compile time error in
+my system, since it was using the nftables/libnftables.h file of the
+previous nftables release.
+
+Fixes: 5b364657a35f ("build: missing SUBIRS update")
+Fixes: caf2a6ad2d22 ("examples: add libnftables example program")
+Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
+---
+ examples/Makefile.am | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -1,4 +1,6 @@
+-noinst_PROGRAMS = nft-buffer \
++check_PROGRAMS = nft-buffer \
+ nft-json-file
+
++AM_CPPFLAGS = -I$(top_srcdir)/include
++
+ LDADD = $(top_builddir)/src/libnftables.la