aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/nftables/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2020-09-01 14:05:12 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2020-09-06 20:30:18 +0200
commit103225b4127dbcc7747b4fb8d4f4d7e2c89ed67a (patch)
tree97c57d7b0afbbb657749853f802d923cdaba1ca3 /package/network/utils/nftables/Makefile
parent56c2e9fe3732ef2cb1f7d764490655e909f63498 (diff)
downloadupstream-103225b4127dbcc7747b4fb8d4f4d7e2c89ed67a.tar.gz
upstream-103225b4127dbcc7747b4fb8d4f4d7e2c89ed67a.tar.bz2
upstream-103225b4127dbcc7747b4fb8d4f4d7e2c89ed67a.zip
nftables: Activate link time optimization (LTO)
The ipk sizes for mips_24Kc change like this: old: nftables-json_0.9.6-1_mips_24kc.ipk 231.968 nftables-nojson_0.9.6-1_mips_24kc.ipk 204.731 new: nftables-json_0.9.6-2_mips_24kc.ipk 221.894 nftables-nojson_0.9.6-2_mips_24kc.ipk 193.932 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/network/utils/nftables/Makefile')
-rw-r--r--package/network/utils/nftables/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/network/utils/nftables/Makefile b/package/network/utils/nftables/Makefile
index 8f6e605715..7830596e84 100644
--- a/package/network/utils/nftables/Makefile
+++ b/package/network/utils/nftables/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nftables
PKG_VERSION:=0.9.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://netfilter.org/projects/$(PKG_NAME)/files
@@ -58,6 +58,9 @@ ifeq ($(BUILD_VARIANT),json)
CONFIGURE_ARGS += --with-json
endif
+TARGET_CFLAGS += -flto
+TARGET_LDFLAGS += -flto
+
define Package/nftables/install/Default
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/nft $(1)/usr/sbin/