aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/linux-atm/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-14 11:02:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-14 11:02:12 +0000
commit510f5a7209fc4d3127c597aeaefbb89fa54b7fe1 (patch)
tree5aa3f895c1de94d818d799937ae735d448c39f2d /package/network/utils/linux-atm/Makefile
parentc0f4c9e0d82e7b8be4b81eaa9107517a9d9c9702 (diff)
downloadupstream-510f5a7209fc4d3127c597aeaefbb89fa54b7fe1.tar.gz
upstream-510f5a7209fc4d3127c597aeaefbb89fa54b7fe1.tar.bz2
upstream-510f5a7209fc4d3127c597aeaefbb89fa54b7fe1.zip
linux-atm: add wrapper for br2684ctl to defer nasX device bringup
Fixes a race condition on netifd device bringup. Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47891
Diffstat (limited to 'package/network/utils/linux-atm/Makefile')
-rw-r--r--package/network/utils/linux-atm/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/network/utils/linux-atm/Makefile b/package/network/utils/linux-atm/Makefile
index 51e604c0bb..9c6cfec95c 100644
--- a/package/network/utils/linux-atm/Makefile
+++ b/package/network/utils/linux-atm/Makefile
@@ -182,7 +182,10 @@ define Package/br2684ctl/install
$(INSTALL_BIN) ./files/br2684ctl $(1)/etc/init.d/
$(INSTALL_DATA) ./files/atm.hotplug $(1)/etc/hotplug.d/atm/00-trigger
$(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/br2684ctl $(1)/usr/sbin/
+ $(INSTALL_BIN) \
+ ./files/br2684ctl_wrap \
+ $(PKG_INSTALL_DIR)/usr/sbin/br2684ctl \
+ $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,linux-atm))