aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/linux-atm/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-04 17:44:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-04 17:44:00 +0000
commit1d1265b40bbb15e8bb64d0424f2f1b9d2bfce8f2 (patch)
tree8ac42298a85cdbe7927e200187c995077439e0d5 /package/network/utils/linux-atm/Makefile
parent435e7fb2955833118880c4dc0bffb19a40651bbc (diff)
downloadupstream-1d1265b40bbb15e8bb64d0424f2f1b9d2bfce8f2.tar.gz
upstream-1d1265b40bbb15e8bb64d0424f2f1b9d2bfce8f2.tar.bz2
upstream-1d1265b40bbb15e8bb64d0424f2f1b9d2bfce8f2.zip
br2684ctl: convert init script to procd, add hotplug/reload support
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47765
Diffstat (limited to 'package/network/utils/linux-atm/Makefile')
-rw-r--r--package/network/utils/linux-atm/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/network/utils/linux-atm/Makefile b/package/network/utils/linux-atm/Makefile
index d9402c3c16..51e604c0bb 100644
--- a/package/network/utils/linux-atm/Makefile
+++ b/package/network/utils/linux-atm/Makefile
@@ -178,8 +178,9 @@ define Package/atm-diagnostics/install
endef
define Package/br2684ctl/install
- $(INSTALL_DIR) $(1)/etc/init.d/
+ $(INSTALL_DIR) $(1)/etc/init.d $(1)/etc/hotplug.d/atm
$(INSTALL_BIN) ./files/br2684ctl $(1)/etc/init.d/
+ $(INSTALL_DATA) ./files/atm.hotplug $(1)/etc/hotplug.d/atm/00-trigger
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/br2684ctl $(1)/usr/sbin/
endef