aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iputils/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-08-03 10:45:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-08-03 10:45:36 +0000
commit49d00e95dbbf5413098527755ac42f4f15132220 (patch)
treedade0343b6a89d3dfe9a6ee7224c2ec1e868c935 /package/network/utils/iputils/Makefile
parent3e0247b95fa2aea8f09b025d4364b56a5f92d955 (diff)
downloadupstream-49d00e95dbbf5413098527755ac42f4f15132220.tar.gz
upstream-49d00e95dbbf5413098527755ac42f4f15132220.tar.bz2
upstream-49d00e95dbbf5413098527755ac42f4f15132220.zip
iputils: add missing includes, fix musl support
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 41958
Diffstat (limited to 'package/network/utils/iputils/Makefile')
-rw-r--r--package/network/utils/iputils/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/network/utils/iputils/Makefile b/package/network/utils/iputils/Makefile
index eeb6deb900..19061ca77a 100644
--- a/package/network/utils/iputils/Makefile
+++ b/package/network/utils/iputils/Makefile
@@ -121,10 +121,14 @@ define Package/iputils-traceroute6/description
Traces path to a network host (IPv6).
endef
+ifdef CONFIG_USE_MUSL
+ TARGET_CFLAGS += -D__UCLIBC__
+endif
+
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(TARGET_LDFLAGS)" \
CONFIG_IPV6="$(CONFIG_IPV6)" \
- CONFIG_USE_UCLIBC="$(CONFIG_USE_UCLIBC)" \
+ CONFIG_USE_UCLIBC="$(CONFIG_USE_UCLIBC)$(CONFIG_USE_MUSL)" \
define Package/iputils-arping/install
$(INSTALL_DIR) $(1)/usr/bin