aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iptables
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-04-07 13:20:11 +0200
committerFelix Fietkau <nbd@nbd.name>2017-04-12 10:51:36 +0200
commit5e2d15b4a6fc979497b252c617c4b353d6c84fa2 (patch)
tree4c436e128e648a6254fa327caee11157bd715978 /package/network/utils/iptables
parent98e43b13a7f0f747d4625ba0209ba37ae22f3b48 (diff)
downloadupstream-5e2d15b4a6fc979497b252c617c4b353d6c84fa2.tar.gz
upstream-5e2d15b4a6fc979497b252c617c4b353d6c84fa2.tar.bz2
upstream-5e2d15b4a6fc979497b252c617c4b353d6c84fa2.zip
iptables: set ABI_VERSION to force rebuild of dependent packages
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/network/utils/iptables')
-rw-r--r--package/network/utils/iptables/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 2fef0aba19..ae2377e578 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -402,6 +402,7 @@ $(call Package/iptables/Default)
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+libip4tc +libip6tc +libxtables
+ ABI_VERSION:=$(PKG_VERSION)
TITLE:=IPv4/IPv6 firewall - shared libiptc library (compatibility stub)
endef
@@ -410,6 +411,7 @@ $(call Package/iptables/Default)
SECTION:=libs
CATEGORY:=Libraries
TITLE:=IPv4 firewall - shared libiptc library
+ ABI_VERSION:=$(PKG_VERSION)
DEPENDS:=+libxtables
endef
@@ -418,6 +420,7 @@ $(call Package/iptables/Default)
SECTION:=libs
CATEGORY:=Libraries
TITLE:=IPv6 firewall - shared libiptc library
+ ABI_VERSION:=$(PKG_VERSION)
DEPENDS:=+libxtables
endef
@@ -426,6 +429,7 @@ define Package/libxtables
SECTION:=libs
CATEGORY:=Libraries
TITLE:=IPv4/IPv6 firewall - shared xtables library
+ ABI_VERSION:=$(PKG_VERSION)
DEPENDS:= \
+IPTABLES_CONNLABEL:libnetfilter-conntrack \
+IPTABLES_NFTABLES:libnfnetlink