aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2019-06-19 20:25:43 +0100
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2019-06-20 21:12:24 +0100
commita8f0c02f80fa0c7c55702770b3ca99f6db5405e7 (patch)
treef844a0a60f02e05a7d689bf27e4ad3b06b309c12 /package/network/utils/iproute2
parent5273fb6b21b953428e2f9ea5892872db5aaf22c1 (diff)
downloadupstream-a8f0c02f80fa0c7c55702770b3ca99f6db5405e7.tar.gz
upstream-a8f0c02f80fa0c7c55702770b3ca99f6db5405e7.tar.bz2
upstream-a8f0c02f80fa0c7c55702770b3ca99f6db5405e7.zip
iproute2: update ctinfo support
Follow upstream changes - header file changes only no functional or executable changes, hence no package bump required Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'package/network/utils/iproute2')
-rw-r--r--package/network/utils/iproute2/patches/090-tc-add-support-for-action-act_ctinfo.patch15
1 files changed, 5 insertions, 10 deletions
diff --git a/package/network/utils/iproute2/patches/090-tc-add-support-for-action-act_ctinfo.patch b/package/network/utils/iproute2/patches/090-tc-add-support-for-action-act_ctinfo.patch
index 7c36fd9ba0..6335cca03a 100644
--- a/package/network/utils/iproute2/patches/090-tc-add-support-for-action-act_ctinfo.patch
+++ b/package/network/utils/iproute2/patches/090-tc-add-support-for-action-act_ctinfo.patch
@@ -1,4 +1,4 @@
-From b47fffb0f6dc285fe39613a5838e4e50f4f35202 Mon Sep 17 00:00:00 2001
+From dff8eadcab33209e040e77a5d56d5def04808144 Mon Sep 17 00:00:00 2001
From: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Date: Fri, 15 Mar 2019 09:35:37 +0000
Subject: [PATCH] tc: add support for action act_ctinfo
@@ -64,11 +64,11 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Reviewed-by: Toke Høiland-Jørgensen <toke@redhat.com>
---
include/uapi/linux/pkt_cls.h | 3 +-
- include/uapi/linux/tc_act/tc_ctinfo.h | 34 ++++
+ include/uapi/linux/tc_act/tc_ctinfo.h | 29 +++
man/man8/tc-ctinfo.8 | 170 ++++++++++++++++
tc/Makefile | 1 +
tc/m_ctinfo.c | 268 ++++++++++++++++++++++++++
- 5 files changed, 475 insertions(+), 1 deletion(-)
+ 5 files changed, 470 insertions(+), 1 deletion(-)
create mode 100644 include/uapi/linux/tc_act/tc_ctinfo.h
create mode 100644 man/man8/tc-ctinfo.8
create mode 100644 tc/m_ctinfo.c
@@ -89,10 +89,10 @@ index 95d0db2a..a6e7e176 100644
#define TCA_ID_MAX __TCA_ID_MAX
diff --git a/include/uapi/linux/tc_act/tc_ctinfo.h b/include/uapi/linux/tc_act/tc_ctinfo.h
new file mode 100644
-index 00000000..da803e05
+index 00000000..f5f26d95
--- /dev/null
+++ b/include/uapi/linux/tc_act/tc_ctinfo.h
-@@ -0,0 +1,34 @@
+@@ -0,0 +1,29 @@
+/* SPDX-License-Identifier: GPL-2.0 WITH Linux-syscall-note */
+#ifndef __UAPI_TC_CTINFO_H
+#define __UAPI_TC_CTINFO_H
@@ -121,11 +121,6 @@ index 00000000..da803e05
+
+#define TCA_CTINFO_MAX (__TCA_CTINFO_MAX - 1)
+
-+enum {
-+ CTINFO_MODE_DSCP = BIT(0),
-+ CTINFO_MODE_CPMARK = BIT(1)
-+};
-+
+#endif
diff --git a/man/man8/tc-ctinfo.8 b/man/man8/tc-ctinfo.8
new file mode 100644