aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/patches/300-ip_tiny.patch
diff options
context:
space:
mode:
authorRussell Senior <russell@personaltelco.net>2017-11-27 23:15:50 -0800
committerHans Dedecker <dedeckeh@gmail.com>2017-12-06 22:30:00 +0100
commitc3c1185d56abbae471c3d0bb0477349f79f5d3bb (patch)
tree49c5a8a3402c636b613736ab8b027c11e8f8a165 /package/network/utils/iproute2/patches/300-ip_tiny.patch
parent711a816770b0447ab37fa709251605d7402e4fec (diff)
downloadupstream-c3c1185d56abbae471c3d0bb0477349f79f5d3bb.tar.gz
upstream-c3c1185d56abbae471c3d0bb0477349f79f5d3bb.tar.bz2
upstream-c3c1185d56abbae471c3d0bb0477349f79f5d3bb.zip
iproute2: update to v4.14.1
Preserves optionality of libmnl by letting configuration script follow the HAVE_MNL environment variable. Signed-off-by: Russell Senior <russell@personaltelco.net>
Diffstat (limited to 'package/network/utils/iproute2/patches/300-ip_tiny.patch')
-rw-r--r--package/network/utils/iproute2/patches/300-ip_tiny.patch22
1 files changed, 11 insertions, 11 deletions
diff --git a/package/network/utils/iproute2/patches/300-ip_tiny.patch b/package/network/utils/iproute2/patches/300-ip_tiny.patch
index d48ea8581c..813d579434 100644
--- a/package/network/utils/iproute2/patches/300-ip_tiny.patch
+++ b/package/network/utils/iproute2/patches/300-ip_tiny.patch
@@ -1,8 +1,8 @@
--- a/ip/Makefile
+++ b/ip/Makefile
-@@ -28,6 +28,13 @@ ifeq ($(HAVE_MNL),y)
- LDLIBS += $(shell $(PKG_CONFIG) libmnl --libs)
- endif
+@@ -15,6 +15,13 @@ RTMONOBJ=rtmon.o
+
+ include ../config.mk
+STATIC_SYM_FILTER:=
+ifeq ($(IP_CONFIG_TINY),y)
@@ -14,7 +14,7 @@
ALLOBJ=$(IPOBJ) $(RTMONOBJ)
SCRIPTS=ifcfg rtpr routel routef
TARGETS=ip rtmon
-@@ -57,7 +64,7 @@ else
+@@ -44,7 +51,7 @@ else
ip: static-syms.o
static-syms.o: static-syms.h
@@ -72,7 +72,7 @@
{ "help", do_help },
--- a/lib/utils.c
+++ b/lib/utils.c
-@@ -787,6 +787,7 @@ const char *rt_addr_n2a_r(int af, int le
+@@ -817,6 +817,7 @@ const char *rt_addr_n2a_r(int af, int le
return inet_ntop(af, addr, buf, buflen);
case AF_MPLS:
return mpls_ntop(af, addr, buf, buflen);
@@ -80,7 +80,7 @@
case AF_IPX:
return ipx_ntop(af, addr, buf, buflen);
case AF_DECnet:
-@@ -796,6 +797,7 @@ const char *rt_addr_n2a_r(int af, int le
+@@ -826,6 +827,7 @@ const char *rt_addr_n2a_r(int af, int le
memcpy(dna.a_addr, addr, 2);
return dnet_ntop(af, &dna, buf, buflen);
}
@@ -90,14 +90,14 @@
default:
--- a/lib/Makefile
+++ b/lib/Makefile
-@@ -12,6 +12,10 @@ ifeq ($(HAVE_MNL),y)
- CFLAGS += -DHAVE_LIBMNL $(shell $(PKG_CONFIG) libmnl --cflags)
- endif
+@@ -2,6 +2,10 @@ include ../config.mk
+
+ CFLAGS += $(FPIC)
+ifeq ($(IP_CONFIG_TINY),y)
+ CFLAGS += -DIPROUTE2_TINY
+endif
+
- CFLAGS += $(FPIC)
-
UTILOBJ = utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o \
+ inet_proto.o namespace.o json_writer.o json_print.o \
+ names.o color.o bpf.o exec.o fs.o