aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2019-12-05 22:46:50 +0100
committerHans Dedecker <dedeckeh@gmail.com>2019-12-06 18:35:55 +0100
commit39d9010c20a08ac1ac48f1bec4332bfd92d8b1a6 (patch)
tree52a9e62d35555179e982f9c86afbde8b100b4e3a /package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
parenta512123a4bef7a83cc2d9dd64f7f8cfb1c3a7bf5 (diff)
downloadupstream-39d9010c20a08ac1ac48f1bec4332bfd92d8b1a6.tar.gz
upstream-39d9010c20a08ac1ac48f1bec4332bfd92d8b1a6.tar.bz2
upstream-39d9010c20a08ac1ac48f1bec4332bfd92d8b1a6.zip
iproute2: update to 5.4.0
Update iproute2 to latest stable version, see https://lwn.net/Articles/805654/ for the changes in 5.4.0 Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch')
-rw-r--r--package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch b/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
index d3f6a262d6..0385bd737b 100644
--- a/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
+++ b/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
@@ -1,6 +1,6 @@
--- a/tc/Makefile
+++ b/tc/Makefile
-@@ -110,7 +110,7 @@ LDLIBS += -L. -lm
+@@ -111,7 +111,7 @@ LDLIBS += -L. -lm
ifeq ($(SHARED_LIBS),y)
LDLIBS += -ldl
@@ -9,7 +9,7 @@
endif
TCLIB := tc_core.o
-@@ -140,7 +140,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
+@@ -141,7 +141,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
all: tc $(TCSO)
tc: $(TCOBJ) $(LIBNETLINK) libtc.a
@@ -18,7 +18,7 @@
libtc.a: $(TCLIB)
$(QUIET_AR)$(AR) rcs $@ $^
-@@ -162,6 +162,7 @@ install: all
+@@ -163,6 +163,7 @@ install: all
clean:
rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.yacc.h; \
rm -f emp_ematch.yacc.*
@@ -26,7 +26,7 @@
q_atm.so: q_atm.c
$(QUIET_CC)$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -shared -fpic -o q_atm.so q_atm.c -latm
-@@ -201,4 +202,15 @@ static-syms.h: $(wildcard *.c)
+@@ -202,4 +203,15 @@ static-syms.h: $(wildcard *.c)
sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
done > $@