aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iperf3/Makefile
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2017-07-30 18:59:50 -0600
committerJohn Crispin <john@phrozen.org>2017-08-23 20:35:16 +0200
commitd55fff4ae7c77cad820fe37cb3cad4ba6ced1eb8 (patch)
tree28d8b9a49f1a676f930287ef3ac31131bef250dc /package/network/utils/iperf3/Makefile
parente665b3df2a47ba5bb049d13358937ac67b860b70 (diff)
downloadupstream-d55fff4ae7c77cad820fe37cb3cad4ba6ced1eb8.tar.gz
upstream-d55fff4ae7c77cad820fe37cb3cad4ba6ced1eb8.tar.bz2
upstream-d55fff4ae7c77cad820fe37cb3cad4ba6ced1eb8.zip
iperf3: update to 3.2
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'package/network/utils/iperf3/Makefile')
-rw-r--r--package/network/utils/iperf3/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/package/network/utils/iperf3/Makefile b/package/network/utils/iperf3/Makefile
index ee510737f5..853636488c 100644
--- a/package/network/utils/iperf3/Makefile
+++ b/package/network/utils/iperf3/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=iperf
-PKG_VERSION:=3.1.7
+PKG_VERSION:=3.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://downloads.es.net/pub/iperf
-PKG_HASH:=a4ef73406fe92250602b8da2ae89ec53211f805df97a1d1d629db5a14043734f
+PKG_HASH:=f207b36f861485845dbdf09f909c62f3d2222a3cf3d2682095aede8213cd9c1d
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=BSD-3-Clause
@@ -23,15 +23,19 @@ PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
+DISABLE_NLS:=
+
define Package/iperf3
SECTION:=net
CATEGORY:=Network
TITLE:=Internet Protocol bandwidth measuring tool
URL:=https://github.com/esnet/iperf
+ DEPENDS:= +libopenssl
endef
TARGET_CFLAGS += -D_GNU_SOURCE
-CONFIGURE_ARGS += --disable-shared
+CONFIGURE_ARGS += --disable-shared \
+ --with-openssl="$(STAGING_DIR)/usr"
MAKE_FLAGS += noinst_PROGRAMS=