aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/curl
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2017-10-06 10:53:51 +0200
committerHans Dedecker <dedeckeh@gmail.com>2017-10-07 19:17:44 +0200
commit778970735bb5ef6727d381f85a03873ec1ca3998 (patch)
treedfb0471f330891fa477c30d3e6609136ebaf6750 /package/network/utils/curl
parent0e265dc0c704bced105980f1bee2a95827a29f25 (diff)
downloadupstream-778970735bb5ef6727d381f85a03873ec1ca3998.tar.gz
upstream-778970735bb5ef6727d381f85a03873ec1ca3998.tar.bz2
upstream-778970735bb5ef6727d381f85a03873ec1ca3998.zip
curl: add nghttp2 support
Add config option support for nghttp2 Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package/network/utils/curl')
-rw-r--r--package/network/utils/curl/Config.in4
-rw-r--r--package/network/utils/curl/Makefile7
2 files changed, 9 insertions, 2 deletions
diff --git a/package/network/utils/curl/Config.in b/package/network/utils/curl/Config.in
index 6f72134731..973da3d964 100644
--- a/package/network/utils/curl/Config.in
+++ b/package/network/utils/curl/Config.in
@@ -101,6 +101,10 @@ config LIBCURL_TFTP
bool "TFTP protocol"
default n
+config LIBCURL_NGHTTP2
+ bool "HTTP2 protocol"
+ default n
+
comment "Miscellaneous"
config LIBCURL_PROXY
diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index 330d8d518c..634da04657 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=curl
PKG_VERSION:=7.55.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
@@ -53,6 +53,7 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_LIBCURL_SMTP \
CONFIG_LIBCURL_TELNET \
CONFIG_LIBCURL_TFTP \
+ CONFIG_LIBCURL_NGHTTP2 \
\
CONFIG_LIBCURL_COOKIES \
CONFIG_LIBCURL_CRYPTO_AUTH \
@@ -85,7 +86,8 @@ define Package/libcurl
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:= +LIBCURL_WOLFSSL:libwolfssl +LIBCURL_OPENSSL:libopenssl +LIBCURL_GNUTLS:libgnutls +LIBCURL_MBEDTLS:libmbedtls
- DEPENDS += +LIBCURL_ZLIB:zlib +LIBCURL_THREADED_RESOLVER:libpthread +LIBCURL_LDAP:libopenldap +LIBCURL_LIBIDN:libidn +LIBCURL_SSH2:libssh2
+ DEPENDS += +LIBCURL_ZLIB:zlib +LIBCURL_THREADED_RESOLVER:libpthread +LIBCURL_LDAP:libopenldap +LIBCURL_LIBIDN:libidn
+ DEPENDS += +LIBCURL_SSH2:libssh2 +LIBCURL_NGHTTP2:libnghttp2
TITLE:=A client-side URL transfer library
MENU:=1
endef
@@ -119,6 +121,7 @@ CONFIGURE_ARGS += \
$(if $(CONFIG_LIBCURL_LIBIDN),--with-libidn="$(STAGING_DIR)/usr",--without-libidn) \
$(if $(CONFIG_LIBCURL_SSH2),--with-libssh2="$(STAGING_DIR)/usr",--without-libssh2) \
$(if $(CONFIG_LIBCURL_ZLIB),--with-zlib="$(STAGING_DIR)/usr",--without-zlib) \
+ $(if $(CONFIG_LIBCURL_NGHTTP2),--with-nghttp2="$(STAGING_DIR)/usr",--without-nghttp2) \
\
$(call autoconf_bool,CONFIG_LIBCURL_DICT,dict) \
$(call autoconf_bool,CONFIG_LIBCURL_FILE,file) \